Hello There, Guest! Register

Metal Gear Solid 4: Guns of Patriots [BLES00246]
#21
(07-11-2016, 03:53 PM)Ekaseo Wrote: its true that certain games wont work, those are online only games that require you to connect to psn to play.
This emulator does not emulate the OS, just the hardware. Its still in early alpha, most games dont work, and the devs dont develop to make a certain game work (meaning implementing everything specific that the game needs), they work on everything that needs to be done.

Do you know anything about blackbird progression lately?
Reply
#22
(07-12-2016, 09:42 PM)NakedSaru Wrote:
(07-11-2016, 03:53 PM)Ekaseo Wrote: its true that certain games wont work, those are online only games that require you to connect to psn to play.
This emulator does not emulate the OS, just the hardware. Its still in early alpha, most games dont work, and the devs dont develop to make a certain game work (meaning implementing everything specific that the game needs), they work on everything that needs to be done.

Do you know anything about blackbird progression lately?

Why he should know about blackbird's progression? You can just ask himself.

P.S. blackbird is not developer, just a user...
Reply
#23
(07-13-2016, 01:59 AM)Darkriot Wrote:
(07-12-2016, 09:42 PM)NakedSaru Wrote:
(07-11-2016, 03:53 PM)Ekaseo Wrote: its true that certain games wont work, those are online only games that require you to connect to psn to play.
This emulator does not emulate the OS, just the hardware. Its still in early alpha, most games dont work, and the devs dont develop to make a certain game work (meaning implementing everything specific that the game needs), they work on everything that needs to be done.

Do you know anything about blackbird progression lately?

Why he should know about blackbird's progression? You can just ask himself.

P.S. blackbird is not developer, just a user...

Because he seems to not answer :/
Reply
#24
Hi, newcomer here.

I've tried to run MGS4 with the latest build (at the time of writing this): 5f15c661 (28/08/06 I believe). Still no luck Sad .

I don't know if its useful to anyone, but here's my log.

http://slexy.org/view/s2pVIIAHTW

Settings
=======================
Aspect ratio: 16x9
D3D12 / NVIDIA GeForce GT 630
Frame limit: Off
Resolution: 1280x720
VSync: false
Write Color Buffers: false
Write Depth Buffer: false

If anyone spots an error, I'm available to re-test with different settings, though I doubt they'll make a difference at this point.

Cheers!
Reply
#25
It's crashing the emulator for me...

Version: 13493ec0

LLE: audio, font, fontFT, freetype, freetypeTT, fs, spurs_jq, sre


Black render window with 0.00 fps shows up then after a moment the emulator crashes.
Reply
#26
(02-01-2017, 10:34 AM)Renusek Wrote: Black render window with 0.00 fps shows up then after a moment the emulator crashes.

As expected.
Reply
#27
I'm actually quite surprised that no one tried this lately. 01ef9ec build, OpenGL renderer and modules:
audio, font, fontFT, freetype, freetypeTT, fs, resc, rtc, spurs_jq, sre
Intel HD Graphics 4600 (I know, I know. My GPU decided to die on me yesterday.) gets me 20fps with a black screen and no audio but the log shows that (I think) the problem is with the file system?
http://pastebin.com/pTi4pWZf
Reply
#28
That's not the log file, only incomplete console output. Attach rpcs3.log, found next to rpcs3.exe. Put it in a .zip.

Also make sure the file structure is really /PS3_GAME/USRDIR/mgs/slot.dat (for example) and that the file PS3_DISC.sfb is next to the folder PS3_GAME (not in it) and that this is not placed in dev_hdd0, put it on your desktop or something and use the boot game menu.
Reply
#29
This is the result of booting the game from the top folder (BLES00246) :

http://pastebin.com/h9wvr5Jg

And this is the result of booting the game using the SELF file:

http://pastebin.com/8NLhVhjt

I'm still getting a grey screen, and the output shows nothing.
At some point all the SPU threads stop:

·W 0:00:00.987812 {SPU[0x2000003] Thread (MGS4_MAINCellSpursKernel3) [0x00818]} SPU: STOP 0x0
·W 0:00:00.987808 {SPU[0x2000002] Thread (MGS4_MAINCellSpursKernel2) [0x00818]} SPU: STOP 0x0
·W 0:00:00.987808 {SPU[0x2000001] Thread (MGS4_MAINCellSpursKernel1) [0x00818]} SPU: STOP 0x0
·W 0:00:00.987807 {SPU[0x2000000] Thread (MGS4_MAINCellSpursKernel0) [0x00818]} SPU: STOP 0x0

At that point I just closed the emulator.

Not sure if this is useful to anybody, though. The game still isn't working, but its not-working in a different way now.
Reply
#30
Loading directly self file is the way to go

BUt strage, its like you have no spurs libraries Loaded... Turn off autoload libraries option and use only basic ones from the forum sticky thread.

EDT auto loas libraries do not work always safely yet.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)