Hello There, Guest! Register

Grand Theft Auto V [BLES01807]
#21
(07-28-2015, 05:23 PM)supergatto Wrote:
(07-28-2015, 04:26 PM)tambre Wrote:
(07-28-2015, 03:39 PM)supergatto Wrote: Here my log...

Are you compiling yourself or using RPCS3 compiled by someone else?
If you're compiling yourself, make sure that you're using the release configuration and "ignore" the error and continue, if possible. Might get somewhere still.

It seems to initialize spurs stuff and a lot of SPU threads early on. My guess is that it's loads data during the intro cutscenes?

I used last revision: cdf38d1
I deleted old boot.bin and after i tried to open gta 5. I tried Resume all the time but this game isn't loadable. I waited 10 minutes and the last error is:
E {PPU[0x1] Thread (main_thread)[0x00a37290]} Exception: Trap! (tw 0x1f, r1, r1)
(in file C:\builds\reps\ps3\rpcs3\rpcs3\Emu/Cell/PPUInterpreter.h:2408, in function PPUInterpreter::TW)
Sorry for my english.

No problem, I guess we might have to wait for it to get fixed.
Reply
#22
If I'm reading the log right executions stops because the game itself calls trap which could for instance happen because something is not right with how spurs was initialized or whatever the error might be.

Even if you ignore it and continue execution I would guess the game will still crash.
Reply
#23
(07-29-2015, 02:44 PM)ssshadow Wrote: If I'm reading the log right executions stops because the game itself calls trap which could for instance happen because something is not right with how spurs was initialized or whatever the error might be.

Even if you ignore it and continue execution I would guess the game will still crash.

Well the implementation of cellSpursCreateTask more or less does nothing, so I expect it to be that.

I wonder if it would work at all with LLE SPURS, though (SPURS is a mess.)
Reply
#24
After months here new log. It don't show anything.

Here last error:
Code:
E {PPU[0x1] Thread (main_thread)[0x00a37290]} Exception: Trap! (tw 0x1f, r1, r1)
(in file C:\TeamCity\buildAgent\work\90bf8ef4931710f\rpcs3\Emu/Cell/PPUInterpreter.h:2427, in function PPUInterpreter::TW)


Reply
#25
New log:

i am using rpcs3-ReleaseLLVM-8e12c4cb
Reply
#26
New log:

I am using rpcs3-ReleaseLLVM-7584f29e
Reply
#27
(03-15-2016, 12:48 PM)supergatto Wrote: New log:

I am using rpcs3-ReleaseLLVM-7584f29e

Please try LLE'in cellSpurs (cellSre)
Reply
#28
(03-15-2016, 03:11 PM)tambre Wrote:
(03-15-2016, 12:48 PM)supergatto Wrote: New log:

I am using rpcs3-ReleaseLLVM-7584f29e

Please try LLE'in cellSpurs (cellSre)
Ok, i used for first cellSre, and here my log:

And show for 3 times

Code:
{SPU[0x25] Thread (PrimaryCellSpursKernel4)[0x0400c]} Exception: Unknown command GETLLAR (cmd=0xd0, lsa=0x3fc80, ea=0x1da3a00, tag=0x0, size=0x0)
(in file C:\rpcs3\rpcs3\Emu\Cell\SPUThread.cpp:498, in function SPUThread::process_mfc_cmd)
and last error is:
Code:
{PPU Thread[0x1] (main_thread)[0x01677964]} Exception: Unknown Win32 error: 0xb7.
From: E:/Giochi/rpcs3-5416782-windows-x86-64/dev_hdd1/game/BLES01807
To: E:/Giochi/rpcs3-5416782-windows-x86-64/dev_hdd0/game/BLES01807
(in file C:\rpcs3\Utilities\File.cpp:342, in function fs::rename)
Reply
#29
(03-16-2016, 10:44 AM)supergatto Wrote:
(03-15-2016, 03:11 PM)tambre Wrote:
(03-15-2016, 12:48 PM)supergatto Wrote: New log:

I am using rpcs3-ReleaseLLVM-7584f29e

Please try LLE'in cellSpurs (cellSre)
Ok, i used for first cellSre, and here my log:

And show for 3 times

Code:
{SPU[0x25] Thread (PrimaryCellSpursKernel4)[0x0400c]} Exception: Unknown command GETLLAR (cmd=0xd0, lsa=0x3fc80, ea=0x1da3a00, tag=0x0, size=0x0)
(in file C:\rpcs3\rpcs3\Emu\Cell\SPUThread.cpp:498, in function SPUThread::process_mfc_cmd)
and last error is:
Code:
{PPU Thread[0x1] (main_thread)[0x01677964]} Exception: Unknown Win32 error: 0xb7.
From: E:/Giochi/rpcs3-5416782-windows-x86-64/dev_hdd1/game/BLES01807
To: E:/Giochi/rpcs3-5416782-windows-x86-64/dev_hdd0/game/BLES01807
(in file C:\rpcs3\Utilities\File.cpp:342, in function fs::rename)

that proplem is becaus te emulator do not rename the file correctly if the game do not use the standart.
go in dev_hdd0/game/
and change BLES01807 to BLES01807_install
on the ps3 ther is a 2 foulder BLES01807 with not files in USRDIR but the same like BLES01807_install
that is how the ps3 renames it after the install.
dont know why the emu dont chanch it correctly.
happens in much games, hoppe the developer change that in the future.
and copy the param.sfo frome the ps3 into the 2 foulders coulld help
Reply
#30
(03-19-2016, 10:15 AM)big200 Wrote: that proplem is becaus te emulator do not rename the file correctly if the game do not use the standart.
go in dev_hdd0/game/
and change BLES01807 to BLES01807_install
on the ps3 ther is a 2 foulder BLES01807 with not files in USRDIR but the same like BLES01807_install
that is how the ps3 renames it after the install.
dont know why the emu dont chanch it correctly.
happens in much games, hoppe the developer change that in the future.
and copy the param.sfo frome the ps3 into the 2 foulders coulld help

I did it and it show, finally
[Image: dz8ayt.jpg]
But when i stop rpcs3 will crash.

Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)