Metal Gear Solid 4 softlocks after the first truck
Started by GoAway896




4 posts in this topic
GoAway896
Member


0
5 posts 2 threads Joined: May 2023
05-09-2023, 07:54 AM -
#1
The game gets stuck in the very beginning after going under the truck. Otherwise the game seems to run fine. I messed about a few months back with Cheat Engine to skip to certain sections of the game, but now that I want to play legit it crashes. I have tried a number of combinations with the settings, but without fail the game gets stuck on a black loading screen. The game does not seem to hard crash.


Attached Files
.rar   RPCS3.rar (Size: 672.56 KB / Downloads: 4)
GoAway896
Member


0
5 posts 2 threads Joined: May 2023
05-12-2023, 04:47 AM -
#2
There is only one method that I assumed would work.
Under the compatibility section is the Special Notes that mentions the Softlocks and Canary Patches.

Problem is that I have not been able to add these patches. If I follow the guide and then try to activate the patch through the menu Manage/Game Patches.
The system says they are not formatted to version 1.2, so it can't be used. I'm not sure what 1.2 means other than the structure of the patch itself.

The supposed patch is for the firmware I have is 4.89

PRX-WHnKAK6U9UApL2YMgjU3c5ozpTUM-0:
  "cellSpurs urgent commands hack - 4.89":
    Games: *MGS4_All_Games
    Author: "elad335"
    Notes: [ *MGS4_SpursHack_Notes_1, "4.89", *MGS4_SpursHack_Notes_2 ]
    Patch Version: 1.0
    Patch:
      - [ be32, 0x000182b8, 0x38000002 ]
 


I've tried making it look like this:

PPU-9712144d93487f0b62e39f55e175af783b58af72:
  "Disable shadows":
    Games:
      "Metal Gear Solid 4: Guns of the Patriots":
        BLUS30109: [ 01.00 ]
    Author: "TriggerHappy"
    Notes: *MGS4_Disableshadows_Notes
    Patch Version: 1.0
    Patch:
      - [ be32, 0x001358b8, 0x4e800020 ]

didn't work
Maybe I forgot a certain character or I just don't know what format 1.2 means
This post was last modified: 05-12-2023, 04:49 AM by GoAway896.
FlexBy
RPCS3 Tester


5
450 posts 272 threads Joined: Nov 2021
05-12-2023, 03:42 PM -
#3
Code:
Version: 1.2
Anchors:
  MGS4_All_Games: &MGS4_All_Games
    "Metal Gear Solid 4: Guns of the Patriots":
      BLES00246: [ All ]
      BLUS30109: [ All ]
      BLJM67001: [ All ]
      NPUB31633: [ All ]
      NPEB02182: [ All ]

  MGS4_SpursHack_Notes_1: &MGS4_SpursHack_Notes_1
    "Workaround for freezes in Metal Gear Solid 4.\nThis patch applies to a firmware file for all games!\nUsage outside of Metal Gear Solid 4 is for debug purposes only.\nYou must have firmware version "
  MGS4_SpursHack_Notes_2: &MGS4_SpursHack_Notes_2
    " in order to use it.\n\nKnown to affect:\n Metal Gear Solid 4"

PRX-WHnKAK6U9UApL2YMgjU3c5ozpTUM-0:
  "cellSpurs urgent commands hack - 4.89":
    Games: *MGS4_All_Games
    Author: "elad335"
    Notes: [ *MGS4_SpursHack_Notes_1, "4.89", *MGS4_SpursHack_Notes_2 ]
    Patch Version: 1.0
    Patch:
      - [ be32, 0x000182b8, 0x38000002 ]
This is how the imported_patch.yml should look like
balls

GoAway896
Member


0
5 posts 2 threads Joined: May 2023
05-12-2023, 05:01 PM -
#4
Well thanks, I was able to apply it.
It still freezes under that truck. So, I guess I need to keep looking.

The only workaround I can think of is just to dust off my real PS3 get past the truck. Which is what I may end up doing. Either that or use the Cheat Engine code, although the codes are for skipping entire chapters (or rather skipping to certain cutscenes like the briefings), I don't know if I can skip just 1 scene. I don't have the full instance document. If I can it will probably appear in cheat engine. However, I don't know if there will be other points like here that it will refuse to load a cutscene.

Kind of defeats the purpose of playing from the start.

The weapon to surpass Metal Gear is just a regular car.
This post was last modified: 05-12-2023, 05:06 PM by GoAway896.
Loacoon
Member


0
15 posts 0 threads Joined: May 2020
06-07-2023, 05:30 PM -
#5
I can't make this patch or any other appear in the list no matter what I try... There seems to be a RPCS bug?! I've done all by the letter. Is it checking the wrong folder on Linux or something?


Forum Jump:


Users browsing this thread: 1 Guest(s)