Need For Speed Shift Problem (BLUS30391).
Started by NickTamer




3 posts in this topic
NickTamer
Member


0
3 posts 1 threads Joined: Apr 2021
04-12-2021, 04:44 PM -
#1
Hello everybody i need help with one game. The Game is Need For Speed Shift (BLUS30391).

The game is working if you remove the trophy folder in the folder of the game and run at 20fps more or less. On my laptop ROG (I7 7700HQ 2.80ghZ, ram 8go and GTX 1050 the game run, but on my other PC ( i5-9400F 2.90GHz ram 8go and GTX 1650) the game crash when get in-game. I used the same version of RPCS3 on the two computers, i've the latest driver's update and the same config for the game and i tried many settings but the game still crash on the second PC and not on the laptop. Any idea ?


Thanks for your help
This post was last modified: 04-14-2021, 07:37 AM by NickTamer.


Attached Files
.7z   RPCS3.7z (Size: 644.2 KB / Downloads: 0)
NickTamer
Member


0
3 posts 1 threads Joined: Apr 2021
04-14-2021, 07:41 AM -
#2
And here the log where the game run without crash on my laptop i7

Sorry for triple post.

New test and still the same, the game run well on my old laptop and crash when in-game on my new PC

How can i fix this for the game playable on my PC ? Any settings ?



Here the new log from my laptop with Recompiler LLVM and write color buffers. The game run at 20 fps
This post was last modified: 04-15-2021, 06:59 AM by NickTamer.


Attached Files Thumbnail(s)
   

.7z   2RPCS3.7z (Size: 602.82 KB / Downloads: 0)
.7z   RPCS3.7z (Size: 766.35 KB / Downloads: 0)
L0WHAWK
Member


0
86 posts 11 threads Joined: May 2023
06-13-2023, 04:38 PM -
#3
Need For Speed SHIFT (BLUS30391)

RPCS3.0.0.28-15179-cedfb95f Alpha | master

CPU:
SPU Decoder = ASMJIT

GPU:
Output Scaling = FidelityFX Super Resolution
Async (multi threaded)
Write Color Buffer = On
Vsync = On
Stretch To Display = On
Multithreaded RSX = On
Asynchronous Texture Streaming = On

My system specs:
Intel 8700k @ 3.70Ghz
16GB DDR4
Nvidia RTX 3080 10GB
Window 11 Home

I raced two races in the career mode. Average FPS was 45-50 during racing, but would drop to 15fps during the menu section. Didn't affect the game at all for me.
This game is very playable, in my opinion.
This game should be marked as playable now
Just use these settings..
CPU:
(ASMJIT) as your SPU decoder.
GPU:
Write Color Buffers = On
Multithreaded RSX = On
Asynchronous Texture Streaming= On

I played for about 2 hours straight, with no lockups. Average FPS during race for me is 55-60.. During menus tho it can get into the upper teens, but if I didn't have the frame counter going, I wouldn't have noticed it running at 15fps, during the menus..

Very smooth game play.
My specs are: intel 8700k, 16gb ddr4-ram, rtx3080, windows 11 home


Attached Files Thumbnail(s)
                           
Ani
Administrator
*******


16
4,200 posts 104 threads Joined: Aug 2017
06-17-2023, 08:08 PM -
#4
You have to do a report in the thread for the game if you want it to be analysed to be moved, this is a support request thread from 2 years ago
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Ryzen 9 5900HX,  Radeon RX 6700M,   2x8G DDR4 3200MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Manjaro Linux


Forum Jump:


Users browsing this thread: 1 Guest(s)