Tales of Graces f [NPUB31133]
Started by Tsubajashi

12 posts in this topic

4,200 posts 104 threads Joined: Aug 2017
12-01-2020, 08:02 AM -
Current commit: 2aa5c437
Requires "Vblank rate" to be changed in order to be Playable

Moving back to Ingame until this issue is solved
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Ryzen 9 5900HX,  Radeon RX 6700M,   2x8G DDR4 3200MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Manjaro Linux

1 posts 0 threads Joined: Apr 2022
Exclamation  04-27-2022, 11:26 PM -
Heya! I've been testing out the emulator for a bit, works GREAT with most things I've tried.
But I noticed this game seems to be weirdly broken and crash on startup, despite the reports ranging from in-game to playable for it? At least for me.
Figured I'd probably ask about it, just in case my settings are just wrong. Though I've tried both Xillia games on the same emulator, on the same system, and those games as well as every other game I tried ran just fine (for the most part).

I've kept updating the emulator every chance I got to see if it'd get fixed (and surprisingly the ERROR MESSAGE has been updated to be more detailed at one point, though it still crashes on startup).
I'm currently on RPCS3 0.0.21-13531-7a434d19 Alpha, to be more precise.
And every time, on boot, after building the shader cache (or loading it if it's already built), it'll freeze up with this specific error:
E SYS: 'cellGameGetParamString' failed with 0x8002cb21 : id 101 is not supported in the current check mode: content_permission::check_mode::hdd_game [1]

I've TRIED using the disc version of the game, too, but it gives almost the exact same error, it just doesn't call it "hdd_game".
I've loaded the correct .rap file into RPCS3 too, right after installing the game itself, so I doubt that's the issue.
I made SURE to use the recommended setings from the game's page (VBlank rate and the like) and have tried both Vulkan and OpenGL, just to be sure it wasn't the renderer that was the issue, but both gave the exact same result and error.
My specs SHOULD be more than enough, especially considering I've ran other games on this with little to no issues? My GPU's an NVidia GTX 970 which has run other emulator stuff with Vulkan just fine.
Everything else should be listed in the log file either way.

I've attached that log file below, made sure to pre-clear the game cache and not run anything else in that instance just to be sure it'd be as clean as possible, too.

EDIT: Update, I've made an issue tracker for updates on this...
Apparently running it via a "default settings" launch makes it work, though obviously that's not going to include VBlank rate and other settings that fix known issues since it's launching with the defaults.
I'm not sure WHAT settings it is exactly that kill the game, but whatever it is it's not documented in its wiki article along with the other recommended settings, or anywhere else for that matter.
This post was last modified: 05-04-2022, 02:28 AM by LazyTomato. Edit Reason: additional info

Attached Files
.gz   RPCS3.log.gz (Size: 63.75 KB / Downloads: 2)

2,053 posts 83 threads Joined: Aug 2017
05-22-2022, 03:50 AM -
Update: Use PS3 Native framelimiter and the game will properly change its fps cap from 30 to 60 for combat and back again. No need to mess with vblank anymore.

Forum Jump:

Users browsing this thread: 1 Guest(s)