The Legend of Heroes: Trails of Cold Steel II [BLUS31597]
Started by foreveryou79

71 posts in this topic

28 posts 0 threads Joined: Sep 2017
09-24-2017, 07:59 PM -
(09-24-2017, 07:46 PM)Wildbreed Wrote: Is it just me or am i getting constant 30 fps in low fps areas using Vulkan and enabling  Vsync

using the latest  build #3488 by kd-11

with openGL i was getting 20ish fps

I knew this game had poor performance with Vulkan using the past builds, but i just decided to try it out now,
and i was like omg constant 30 fps in Ymir whereas i was getting 21 fps using openGL

Please can anyone else confirm..
location : Ymir
using openGL - 19-20 fps
using Vulkan with Vsync enabled - constant 30fps

build #3488 by kd-11

well i'm not typing out my reply in full again, thank you to the forums for deleting another post of mine.  really nice.

vulkan still has texture corruption, (see attached image).  It also seems to have some serious problems in a few areas.  a certain scene in Nord and coming back from Nord, i saw Vulkan get about 2-7 fps during these times.  Luckily the scenes weren't that long.  OpenGL doesn't run as well, but i can go much longer without seeing texture corruption.  so ive been switching up depending on how well Vulkan is running atm.

Attached Files Thumbnail(s)

4 posts 0 threads Joined: Aug 2017
10-19-2017, 11:51 AM -
I noticed in this game while attempting to save the game progress with the latest Master, that RPCS3 would often hang or Segfault in Ubuntu. The terminal output upon the crash would show:
Fatal error:
Segfault reading location 0000000000000000 at 000000000093c4d0.
Please, don't send incorrect reports. Thanks for understanding.
Though in running with OpenGL, while few hangs or crashes are observed during saving, RPCS3 will sometimes fail to save over a previous game progress over an extend period of gameplay. This can be observed in by noticing the lack of a "Saving System Data..." message upon returning to the Camp Menu, and a resaving attempt will list the previous "map" location and not of the most current.

A workaround to the overwrite failure at the moment is to select the "Save New Entry" option within the "Save Data Interface" window. For some reason that forces the game to save the most current progress. (It should be noted that I also have 62 save points in total.)
The attached log file is of the RPCS3 game save crash.
This post was last modified: 10-19-2017, 11:58 AM by Green.

Attached Files
.gz   RPCS3.log.gz (Size: 532.19 KB / Downloads: 1)

1 posts 0 threads Joined: Oct 2017
10-22-2017, 07:48 PM -
So first of all I misclicked and posted without the full story of my problem so I hope that gets deleted and this is posted.

So tried to follow every change I found here on the forums and youtube, people with almost the same specs as me can easily get 30fps while I get 15fps on Ymir and I don't know what to do.
Using the latest build launched on the 21st October
These are my specs:
i7 3770 non k 3.4GHz
AMD R9 390 8GB

[Image: 4nIUR4OzSt6wmK6uzTMW-Q.png]
And these are my settings:
[Image: y7cYKAy-Rv_ULxpQS275DA.png] [Image: _7z3djXRTO2biJcLpAi83g.png]

The first area was all good with 30fps, but then on Ymir and the next few areas I get between 10~15fps...

3 posts 0 threads Joined: Oct 2017
10-24-2017, 03:54 AM -
Your screenshot using OpenGL. Vulkan should have 30 fps in Ymir. 7-15 in Ymir Valley and Lunaria Park and @15 in Misty Legram. Everywhere esle full speed.
Completed this game few days ago. Only 2 issues so far: mixed textures which cures with restarting emulation (every 15-40 min) and sometimes emulation just hungs. @15 hungs in 70+ hours of gameplay.

11 posts 1 threads Joined: Oct 2017
10-25-2017, 02:30 AM -
Why doesn't the high res renderer work for this?

4 posts 0 threads Joined: Aug 2017
10-25-2017, 10:43 PM -
(10-22-2017, 07:48 PM)PescaNova Wrote: ...
The first area was all good with 30fps, but then on Ymir and the next few areas I get between 10~15fps...
The title window in your screenshot is reporting that you are using OpenGL, and not Vulkan for the renderer. Likely that is because you are using a custom config for the game. Custom configurations will override global configurations. (Right-click on the game within the RPCS3 main window, and then select "Configure" there to access the game's custom configuration.) The latest version of RPCS3 addresses the performance issues in Ymir for in Vulkan only.

1 posts 0 threads Joined: Dec 2017
12-14-2017, 07:57 PM -
Have had really good performance all the way up to leaving for luneria park, and then the game started hanging with error F {MFC Thread} MEM: Access violation writing location 0x18191a1b about 5-15 minutes after restart.

looked everywhere but not seen this problem, or, for that matter, a solution.

2 posts 1 threads Joined: Jan 2018
01-09-2018, 04:21 PM -
i have issue on latest build where every cut scene is blurred out(i tried multiple settings,opengl,vulkan etc) nothing really changes
also loading the game sometimes causes whole emulator to freeze.

Attached Files Thumbnail(s)

.rar   logs.rar (Size: 1.57 MB / Downloads: 0)

3 posts 0 threads Joined: Jan 2018
01-18-2018, 03:42 AM -
The game hangs on loading game saves for me.

15 posts 0 threads Joined: Aug 2017
01-18-2018, 06:51 PM -
(01-18-2018, 03:42 AM)MrPeachPuff Wrote: The game hangs on loading game saves for me.

Yeah same here not really playable any more luckily the pc port should be out soon so i will wait for that.

Forum Jump:

Users browsing this thread: 1 Guest(s)