The Legend of Heroes: Trails of Cold Steel [BLUS31572]
Started by M

154 posts in this topic

2 posts 0 threads Joined: Sep 2019
09-24-2019, 09:55 PM -
(09-13-2019, 12:21 AM)Tapper Wrote: Game crashes at load in latest builds, i.e. rpcs3-v0.0.7-8699-52e8747b_win64.

Runs in rpcs3-v0.0.6-8444-112ad9dd_win64 .

But, after the prologue (when you get to the town on the train) it becomes crazy slow, like 6 fps.
Can confirm that it's still continuing as of pcs3-v0.0.7-8769-45941484_win64.
It opens the screen for a second, and than immediately crashes.
The last error message is: E cfg::try_to_enum_value('Automatically load required libraries'): invalid enum value: invalid stoull argument

25 posts 0 threads Joined: Aug 2018
10-09-2019, 01:02 AM -
It appears that there is an issue causing this game to crash at startup on builds newer than 0.0.6-8576. A bug is filed on Github for it. Until then, the only workaround seems to be just use the old version.

2 posts 0 threads Joined: Sep 2019
11-01-2019, 06:54 PM -
Just an update in case anyone didn't hear about the git update , the issue is now fixed as of 9047. So that's one good piece of news.

25 posts 0 threads Joined: Aug 2018
12-17-2019, 12:48 AM -
FWIW, I made it to the end of the game. It looks like save data carryover to ToCS2 also works properly as long as both games are from the same region.
This post was last modified: 12-17-2019, 12:49 AM by Durandal.

Attached Files Thumbnail(s)

20 posts 7 threads Joined: Sep 2020
02-14-2022, 07:13 AM -
RPCS3 v0.0.20-13282-2d5d5746 Alpha | HEAD
Intel® Core™ i9-10900KF CPU @ 3.70GHz | 20 Threads | 31.88 GiB RAM | TSC: 3.696GHz | AVX+ | FMA3
Operating system: Windows, Major: 10, Minor: 0, Build: 19044, Service Pack: none, Compatibility mode: 0
Qt version: Compiled against Qt 5.15.2 | Run-time uses Qt 5.15.2
Thread time: 0.000000s (0.001112Gc); Faults: 0 [rsx:0, spu:0]; [soft:0 hard:0]; Switches:[vol:0 unvol:0]; Wait:[0.000s, spur:0]
·! 0:00:00.004095 SYS: Initialization times before main(): 0.073078Gc
·! 0:00:00.004101 SYS: argc: 1, argv: 'C:\rpcs3\rpcs3.exe'
·A 0:00:00.058525 {Vulkan Device Enumeration Thread} RSX: Found vulkan-compatible GPU: 'NVIDIA GeForce RTX 2080' running on driver 511.23.0.0
·! 0:00:00.060091 {Vulkan Device Enumeration Thread} SIG: Thread time: 0.031250s (0.128740Gc); Faults: 0 [rsx:0, spu:0]; [soft:0 hard:0]; Switches:[vol:0 unvol:0]; Wait:[0.000s, spur:0]
·! 0:00:00.060117 CFG: Setting the default renderer to Vulkan. Default GPU: 'NVIDIA GeForce RTX 2080')

For me the game hangs right after the first mini-boss fight when the railway guns are being run out (in the pre-prologue).  Right after Rean screams "Stop!" the screen goes black and audio cuts off.  The fps counter keeps going, dipping occasionally like it's running something, but no video or audio output.

Using saves and switching to ASMJIT got me past that point, but before Rean has control in the town it hung again, black screen with no audio or video.

Tried it again, using Dynamic Interpreter, and again it hung after the miniboss fight.

Then I tried it with static interpreter, openGL and SPU loop detection, that worked but animations were slowed down a lot.  I noticed the BGM did not start looping at all, which it normally seems to do after about a minute or so.

1st log (ASMJIT) - 
.gz   RPCS3.log.gz (Size: 759.52 KB / Downloads: 0)

2nd log (Dynamic Interpreter) - 
.gz   RPCS3-2.log.gz (Size: 286.48 KB / Downloads: 0)

3rd log (Static Interpreter) - 
.gz   RPCS3-3.log.gz (Size: 974.71 KB / Downloads: 0)

Forum Jump:

Users browsing this thread: 2 Guest(s)