Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102]
Started by tr4nquility

102 posts in this topic

7 posts 0 threads Joined: Feb 2018
02-09-2018, 05:47 PM -
Town map seems to be finally working!
Tested this with Vulcan + PPU interpreter (fast) + SPU interpreter (fast) (i7, NVidia GTX), entered and left town map for 10 times, and everything was OK.
If emulated with PPU recompiler, it always crashes when you enter town map for 2nd time with the same error, memory access violation 0x0.
If emulated with SPU recompiler, it crashes with either random memory access violation, or emulator stopped working error, or sometimes it even works.
So I think it is something about recompilers that keeps crashing this game.

P.S. Item synthesis is still broken, works once or twice, then hangs after ingredient selection with another memory access violation. Used to crash at a different moment before, though.
This post was last modified: 02-10-2018, 07:07 AM by Thanatos.

Attached Files
.7z   PPU crash log.7z (Size: 636.61 KB / Downloads: 0)
.7z   SPU crash log.7z (Size: 504.65 KB / Downloads: 1)
.7z   RPCS3 log working.7z (Size: 1.61 MB / Downloads: 6)

7 posts 0 threads Joined: Feb 2018
03-04-2018, 08:47 AM -
Write color buffers seems to freeze the game after every battle. 
There's also something wrong with screen capture and text screens. Most loading screens or background screens (like in talking mode) get replaced with wrong image after a while, something from battles, menu screens, once I got a background for talking window that was last screen from previous talking window, just blurred. Also first screens in battle seem off, though battle itself lookls fine. And text windows quickly get corrupted, with either black background for some lines, or some pictures instead of these lines.
These bugs seem to appear with all settings, interpreter/recompiler, disable/enable vertex cache, some others.
On the good note, fps is much better.
This post was last modified: 03-04-2018, 08:55 AM by Thanatos.

Attached Files Thumbnail(s)

2 posts 0 threads Joined: Sep 2018
09-07-2018, 08:58 PM -
It seems playable to me, with the caveat that it crashes fairly frequently on memory access violations during screen transitions, which are much more common on Vulkan than OpenGL. I'd guess prob 1-2 crashes per hour right now.  I don't have any photo editing software, here are some screenshots I put up on imgur (the default pngs were too large for attachments).
Settings were defaults (LLVM cpu, ASMJIT spu, 720p, opengl recommended). The hard crash on item synthesis is resolved, though there's still a chance for the screen transition memory access issue.
[Image: SnfQrvO.jpg]
[Image: iFnJq2e.jpg]
[Image: UZcGrjj.jpg]

There's also a sort of slow graphical corruption that occurs after about an hour or so of play on some text. It's very similar to a bug that happens when Vulkan + Use GPU Texture scaling is on, which is really easily reproducible (go into battle and try to use an item). A reload fixes it when it occurs in opengl though.

[Image: a8XaiAg.jpg]

1 posts 0 threads Joined: Nov 2018
11-18-2018, 07:08 PM -
While playing this and watching the log I noticed something about [BLES01102] missing quite a few files. Appears any dump of the game is creating these missing files, even one I've tried to create which is some of the reasons for crashes.

While this is not the only cause of the crashes, it does create issues when certain events are triggered in the game resulting in the character running in place. This doesn't resolve memory access violation errors, these seem to persist along with stability issues at some points.

I mainly replied to this topic to let those who use this version of the game know why it happens. Watching the log it is easy to tell when some of the files fail to load, it is usually because they are missing. For this reason when you have your game disc, it is highly suggested you check and dump you create for your use that the files are all there as that may be the cause of the fail to load or continue if the system is querying the file and it doesn't exist.

All in all, the game does play, but the crashes are still frequent enough that I don't believe it should be moved to playable at this point.

23 posts 1 threads Joined: Jan 2018
11-24-2018, 12:19 AM -
Got a softlock (white screen, infinite loading animation in the corner [that circle]) right after Saki starts praying outside the battle on the beggining of the game on pretty much default settings (PPU LLVM + SPU ASMJIT + Vulcan, no additional things, no WCB). No graphical problems, no sound problems, FPS's through the roof all the way from clicking "Start" until that moment. Went through after setting up 60FPS limit. World Map works without any single problem. Only synthesis goes critical.

Using PPU Interpreter and\or WCB makes game go sloooow and makes some textures go rainbows.
This post was last modified: 11-24-2018, 12:31 AM by Hakj3r.
CPU: Intel I9-9900k @ 4.7 GHz
GPU: Nvidia GeForce GTX1080
RAM: 16GB DDR4 3200
Motherboard: MSI MPG Z390 Gaming Plus

7 posts 0 threads Joined: Feb 2018
03-24-2019, 08:22 AM -
Good news everyone!
This title actually seems playable with these specific settings:
PPU Interpreter (fast)
Texts display properly, battles render properly, backgrounds are properly captured, movies have hiccups but are bearable, even synthesis works!

As for other settings:
PPU LLVM crashes during synthesis, SPU LLVM doesn't render movies properly, GPU Vulcan tends to crash often during area transitions.

Attached Files Thumbnail(s)

34 posts 10 threads Joined: May 2018
03-24-2019, 10:39 AM -
How much time did you play the game?
According to those screenshots,you are at the same location in the game that I randomly started getting the known problems...I may not get them at all or on every attempt.

7 posts 0 threads Joined: Feb 2018
03-25-2019, 05:09 AM -
(03-24-2019, 10:39 AM)vsub Wrote: How much time did you play the game?
According to those screenshots,you are at the same location in the game that I randomly started getting the known problems...I may not get them at all or on every attempt.

Not much, but I sorta remember where all the problems were last times and how to trigger them, like going through monks house having one battle at each side used to break many things very fast, or crafting crashed the game almost guaranteed on 2nd or 3rd attempt. Yeah, it definitely needs more testing, but so far things look good.

1 posts 0 threads Joined: May 2019
05-19-2019, 12:59 PM -
Just tried to play this game today:
Everything worked fine until i had to fight Mute on second battle, crash often during area transitions, can be solved just like Thanatos wrote.
However, after i get captured by Mute and going to break out of jail, every time i take the ladder, there is a chance that memory access violation 0x0 occurs no matter what i choose (used latest master build at the time i wrote this).
So far, i don't think this game is playable at this point.

9 posts 1 threads Joined: Sep 2017
09-04-2019, 06:27 AM -
Game still randomly freezes. Today before second battle from game beginning, yesterday it was after it...
Last message in log:
F {RSX [0x005b988]} RSX: class std::runtime_error thrown: Verification failed:
(in file C:\projects\rpcs3\rpcs3\Emu\RSX\GL\GLTextureCache.h:383)

.7z   RPCS3.7z (Size: 366.36 KB / Downloads: 5)

Forum Jump:

Users browsing this thread: 1 Guest(s)