The Last Of Us: Part 1 unplayable with Shader Compiling
Started by Unamelable




3 posts in this topic
Unamelable
Member


0
2 posts 1 threads Joined: Apr 2023
04-03-2023, 10:44 PM -
#1
I have already read that contaminating a shader compilation is basically impossible and requires on-the-fly processing. But isn't there really no way to do this in advance, because after loading the location I need to at best leave the game to pause. In order for the compilation to go through. And then just start playing, and not sure that all the shaders will be compiled. All settings are at minimum and still can not play during the compilation, there are solutions? I've already checked how deplorable the PC release of the game, and I'd rather play on an emulator than see PS2-era graphics (it's even prettier) on my build.


CPU: Intel Xeon 1270v2
GPU: GTX 1060 6GB
RAM: 8GB RAM
Game running on HDD, but i guess its doesn't matter if im copy it to SSD.

Game settings (01.11)
[ Patch Manager ]
- Bug Fix: Infected Severed Head Crash
- Bug Fix: University Nailbomb softlock Fix
- Depth border fix
- Disable in-built MLAA
- Disable Mesh Trimming
- Disable Motion Blur
- Disable SSAO
- Enable GPU Lighting
- Speedboost

[CPU]
PPU Decoder: Recompiler LLVM
SPU Decoder: Recompiler LLVM
SPU XFloat Accuracy: Relaxed XFloat
Additional Settings: Enable SPU loop detection (AVX-512 can't be checked)
TSX Instructions can't be changed
SPU Block: Safe
Prefered SPU Threads: 6

[GPU]
Render: Vulkan
GPU: GTX 1060 6GB
Framerate: 30 FPS
Anisotropic Filter: 2x
ZCULL Accuracy: Relaxed
Anti-Aliasing: Auto
Shader Quality: Low
Resolution: HD (1280x720)
Shader Mode: Async (multi threaded)
Number of shader compiler threads: 8
Additional Settings: Write Color Buffers, Multithreaded RSX, Asynchronous Texture Streaming

[Advanced Core]
Accurate DFMA
Accurate RSX reservation access
PPU Non-Java mode fixup
PPU LLVM Precompilation

[Advanced GPU]
Read Depth Buffers
Write Depth Buffers
Read Color Buffers
Vulcan Queue Scheduler: Fast
RSX FIFO Accuracy: Atomic


https://www.mediafire.com/file/kfxrmy5ir...3.log/file
https://www.mediafire.com/file/08614bysi...Y.log/file
Ani
Administrator
*******


16
4,275 posts 105 threads Joined: Aug 2017
04-04-2023, 09:40 PM -
#2
Shader Mode: Async with Shader Interpreter

Besides get, get a better CPU, yours is pretty bad so the game is not going to run well
    Desktop: Ryzen 7 5800X,   Radeon RX 6800 XT, 2x8G DDR4 3600MHz, Manjaro Linux
     Laptop: Ryzen 9 5900HX,  Radeon RX 6700M,   2x8G DDR4 3200MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Manjaro Linux
Unamelable
Member


0
2 posts 1 threads Joined: Apr 2023
04-15-2023, 03:48 PM -
#3
(04-04-2023, 09:40 PM)Ani Wrote: Shader Mode: Async with Shader Interpreter

Besides get, get a better CPU, yours is pretty bad so the game is not going to run well

Okay, i upgraded to Ryzen 5 5500 + RX 6600 XT + 16 GB RAM
I reset my config (set settings from compatability list cfg)
When im trying to use 1080p game crashes with: F {PPU[0x1000000] Thread (main_thread) [0x00a55684]} VM: Access violation reading location 0x0 (unmapped memory)
But if i set to 720 back, problem solves (how to set 1080p with scaling?)
Now when i load game (on SSD). Location is unrendered!
And also how i can disable showing (Compiling Shaders) widow?

Please can you help me with that??


Attached Files
.png   Screenshot_1.png (Size: 368.64 KB / Downloads: 5)
FlexBy
RPCS3 Tester


5
477 posts 286 threads Joined: Nov 2021
04-16-2023, 02:29 PM -
#4
TLOU doesn't support 1080p natively that's why you need to use resolution scale and not change default resolution, the compiling shaders prompt can be disabled in config emulator tab
balls



Forum Jump:


Users browsing this thread: 1 Guest(s)