junktoyWorse performance on newer versions of RPCS3
Started by junktoy




1 posts in this topic
junktoy
Member


0
2 posts 2 threads Joined: Apr 2021
04-20-2021, 12:36 AM -
#1
Recently, after coming across a post about poor performance in the JoJo Eyes of Heaven game, I felt like playing it again. I remembered that the game was running at a constant 30 FPS (I have an i5-4460 with 8 gb of RAM) but after downloading the latest version of the emulator (v0.0.15) I noticed how the FPS dropped to an average of between 10-15. The same happened to me in 2 other games that I had already completed at the time: Nier and Demon Souls. Both games were running perfectly normal before. So the first thing I tried was to scan the PC for viruses. Then I checked that there were no programs open that could affect the performance. Finally, as a last hope, I tried downloading older versions of the emulator. I tried one at a time. First 0.0.14, then 0.0.13, etc. until I finally got to version 0.0.6 which worked as well as I remembered. I also tried version 0.0.5 which worked perfectly. Note that all versions were tested with the default settings.

I mean, i dont have any problem playing with an older version of the emulator. But i find it curious that i can play normally with a really old version instead of the newer ones.
Ani
Administrator
*******


11
3,636 posts 96 threads Joined: Aug 2017
04-20-2021, 11:09 AM -
#2
Try changing Max SPURS Threads on Advanced to 3/4 for Demon's Souls and enable Multi-threaded RSX for NieR
    Desktop: Ryzen 7 2700X,   Radeon RX 6800 XT, 2x8G DDR4 3200MHz, Manjaro Linux
     Laptop: Intel i7 6700HQ, Intel HD 530,      2x8G DDR4 2133MHz, Manjaro Linux
Old Desktop: AMD FX-8350,     Radeon R9 280X,    2x4G DDR3 1600MHz, Windows 7


Forum Jump:


Users browsing this thread: 1 Guest(s)