RPCS3 Forums
Problem in all kingdom hearts franchise - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Support & Issues (https://forums.rpcs3.net/forum-17.html)
+--- Forum: Support (https://forums.rpcs3.net/forum-18.html)
+--- Thread: Problem in all kingdom hearts franchise (/thread-198887.html)

Problem in all kingdom hearts franchise - mohalisad - 06-12-2018

Kingdom hearts is no longer playable for a while in the latest builds but it still is in playable state
If I use rpcs3 0.0.4 I could pass the first cinematic but I have a big problem in all rpcs3 versions and builds and in all version of kingdom hearts include 1,2 ,chain of ...
and that's a black bar under cinematic
I tried opengl vulkan and i tried even on fedora linux but 
[Image: 8znm_capture2222.png]
I know that this game has 2 or 3 cinematics in each version and has more important bugs to fix on latest version that make the game unplayable
but I think this bug isn't a big one and it is a question for me why youtube videos of this game on rpcs3 don't have this problem but I have.
my rig is a msi gtx 1070 and 16gb ram and core i7 7700k

RE: Problem in all kingdom hearts franchise - ggKismet - 06-16-2018

As of 0.0.5-6955, Vulkan API on  Birth by sleep throws this error:
RPCS3: Fatal Error

<p style="white-space: nowrap;">
<p>Unhandled Win32 exception 0xC0000005.<br>
Segfault reading location ffffffffffffffff at 000000000050f2d0.<br>
Instruction address: 000000000050f2d0.<br>
Module name: 'rpcs3.exe'.<br>
Module base: 0000000000010000.<br>
RPCS3 image base: 0000000000010000.<br>
<a href='https://github.com/RPCS3/rpcs3/wiki/How-to-ask-for-Support'>https://github.com/RPCS3/rpcs3/wiki/How-to-ask-for-Support</a><br>
Please, don't send incorrect reports. Thanks for understanding.<br>

amd a10 7860k cpu, gt 1030 gpu, 16gb ram etc etc. Kingdom hearts 2 is still just a black screen. Using default settings for both games, LLVM recompiler/etc. Shame the series has been regressing so hard. Sad