RPCS3 Forums
White Knight Chronicles II [BLUS30784] - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Commercial Games (https://forums.rpcs3.net/forum-4.html)
+--- Forum: Ingame (https://forums.rpcs3.net/forum-6.html)
+--- Thread: White Knight Chronicles II [BLUS30784] (/thread-181409.html)

Pages: 1 2 3


RE: White Knight Chronicles II [BLUS30784] - rockleevk - 03-18-2017

Just tested with rpcs3-v0.0.2-2017-03-12-bd2e1a63 build and does nothing.

Posting log as well on zip file.

Label: Nothing.



RE: White Knight Chronicles II [BLUS30784] - Zardas - 07-31-2017

rpcs3-v0.0.3-2017-07-29-54f990a8_win64

Intro and main menu working. Freezes at character creation. Sometimes shows a downloadable content message before freezing.





RE: White Knight Chronicles II [BLUS30784] - JackPS9 - 09-24-2017

Tested on
rpcs3-v0.0.3-2017-09-23-e7db0c7d_win64
Just getting to character creation than it freezes.
Hoping that it gets further soon, as I really want to play this game again.


RE: White Knight Chronicles II [BLUS30784] - Asinine - 09-13-2018

Ingame as of my test here: https://forums.rpcs3.net/thread-177582.html
Nolonger freezes on character creation screen!


RE: White Knight Chronicles II [BLUS30784] - Asinine - 09-26-2018

Playable as of the test here https://forums.rpcs3.net/thread-177582.html
Cheng from our RPCS3 discord played the game from start to finish with no major reported issues!


RE: White Knight Chronicles II [BLUS30784] - BajaBooch - 10-04-2018

I can't get past the intro without freezing, past character creation though. It's random except for the fact it always freezes. Do I have setting that is messing it up?

Build: rpcs3-v0.0.5-7405-da6ce80f_win64
PPU: LLVM
SPU: ASMJIT / LLVM (same result)
Auto load lib. / liblv2 only (same result)
Render: Vulkan


RE: White Knight Chronicles II [BLUS30784] - Asinine - 10-06-2018

The character creation freeze was fixed only recently it should be working in the build you mentioned though. Your log file is also empty because you didn't upload the file after running the game then closing RPCS3.
Edit: Okay, I just tried 7405 (same build as you) and it didn't freeze during the character creation screen.


RE: White Knight Chronicles II [BLUS30784] - BajaBooch - 10-06-2018

(10-06-2018, 12:12 AM)Asinine Wrote: The character creation freeze was fixed only recently it should be working in the build you mentioned though. Your log file is also empty because you didn't upload the file after running the game then closing RPCS3.
Edit: Okay, I just tried 7405 (same build as you) and it didn't freeze during the character creation screen.

Ok, sorry about that. I attached a log that wasn't an empty file this time Idea I also realized it is more of a soft freeze...? Meaning the video freezes but I still have sound for a bit, but that freezes after a little while anyway. It does seem like its more of a issue on my side since I'm the only one with this problem...?

Edit: I think I figured it out. I deleted all caches, RPCS3 folder and started new. Reinstalled everything, including the 1.01 update (which I was missing). Still freezing but with fatal errors now, still random, but less frequent. This is always past character creation btw.


RE: White Knight Chronicles II [BLUS30784] - Asinine - 10-07-2018

I don't know why it's not working for you :/ works fine for me and cheng. And your settings look fine. But, by "video freezes" do you mean the intro cutscene? Because before you said it was the character creation


RE: White Knight Chronicles II [BLUS30784] - BajaBooch - 10-07-2018

(10-07-2018, 12:18 PM)Asinine Wrote: I don't know why it's not working for you :/ works fine for me and cheng. And your settings look fine. But, by "video freezes" do you mean the intro cutscene? Because before you said it was the character creation

I can see why that was confusing, reading that now I realize I worded that poorly. I meant that it always freezes after character creation either during the loading screen or the intro cutscene. But I did upload a new log with a very strange error (I've never seen in this or any other game) and always occurs (for me) in the intro cutscene where your character is first introduced. 
"·F 0:19:28.928401 {rsx::thread} class std::runtime_error thrown: Unknown magnify filter 0x0"
But usually it throws a Verification Failed error. A couple other things I noticed is:
-For some reason the game installs game data every time I start the game which is new for me
-If I make it to the intro cutscene (after character creation) without freezing with a Verification Failed error I can skip all cutscenes and play with no problems (only been able to play for 5 minutes so far Sad )
Since I'm the only one with these issues I'm beginning to think it's some piece of hardware failing. What do you think?
Edit: Oh ya, it may be important to mention I'm only playing WKC2 game but trying to begin with the first WKC
Edit 2: Figured out the install issue. For some reason if I install the update first RPCS3 won't keep the install data. If I install data first then update no problem...?
Edit 3: Ok so it seems like I have to run the game with Interpreter (Fast) to reliably get in-game (at 5-8 fps) without the Verification Failed error but the Unknown magnify filter error pops up and freezes the game. Nobody else is getting these errors?!? This is so frustrating