RPCS3 Forums
Tales of Vesperia [NPJB90185] - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Commercial Games (https://forums.rpcs3.net/forum-4.html)
+--- Forum: Ingame (https://forums.rpcs3.net/forum-6.html)
+--- Thread: Tales of Vesperia [NPJB90185] (/thread-166378.html)



RE: Tales of Vesperia [NPJB90185] - ps0ne - 12-29-2014

Game displays half screen, log gives some PPU interpreter error
PPU: E {PPU[121] Thread[0x00422620]} PPUInterpreter::LWZ(): invalid address (0x143101329044), eventually game exits itself and crashes.



RE: Tales of Vesperia [NPJB90185] - ssshadow - 12-29-2014

The first thing the game should display is some black text on a white background, so what you see there probably is that, but very broken... It should then play a video.

Needs spurs to get further though.



RE: Tales of Vesperia [NPJB90185] - Ru4slan - 12-30-2014

(12-29-2014, 03:31 PM)ssshadow Wrote: The first thing the game should display is some black text on a white background, so what you see there probably is that, but very broken... It should then play a video.

Needs spurs to get further though.

Yes.Need CellSpursEventFlagWait for Far Cry 3, 4.Two(or three) threads uses this.This function infinite load(in RSX debugger show load screen).



RE: Tales of Vesperia [NPJB90185] - GeniusMage - 03-14-2017

Setup:
i7 2600K
AMD Radeon R9 Nano

Settings:
OpenGL 1280x720
PPU decoder : Interpreter (fast)
SPU decoder : Recompiler (ASMJIT)
XAudio2

Screenshots:

Intro video plays at ~3fps.

Main menu is not visible, but it works.

Starting a new game takes you to the option menu.

In-game. Progressing further seems possible, but extremely tricky...

Skit and in-game menu.

Also:
- OpenGL causes red flickering in menus and on the intro video. Using it may cause seizures... Using Vulkan solves this problem (EDIT : solved by changing the resolution to 720x480).
- Vulkan has less visual effects showing, and half of the screen is missing during skits. Everything else is the same (EDIT : After further testing, Vulkan only displays a few lines of pixels correctly in battle and on the World Map).
- DirectX12 crashes when arriving at the main menu.
- Saving/loading works.
- Overall, game runs slowly, at around 5fps.
- Using PPU Recompiler (LLVM) makes videos run at correct 24fps, but there is no visual output (black screen with audio). Also the game hangs after the option menu (EDIT : loading a save in a dungeon seems to cause infinite loops, loading a save on the World Map causes a fatal error :
"Unhandled Win32 exception 0xC0000005.
Segfault reading location 0000000100da9a08 at 00000000109aa788.
Instruction address: 00000000109aa788.
Function address: 00000000109aa6d0 (base+0x9aa6d0).
RPCS3 image base: 0000000000010000.&quotWink.



RE: Tales of Vesperia [NPJB90185] - kulisse - 03-14-2017

Which libraries are you using?



RE: Tales of Vesperia [NPJB90185] - ssshadow - 03-14-2017

(03-14-2017, 06:16 PM)kulisse Wrote: Which libraries are you using?

To quote the log file:

Code:
Load libraries:
    []
Load required libraries: true

Auto selection.



RE: Tales of Vesperia [NPJB90185] - GeniusMage - 03-24-2017

"rsx: Do not create new surfaces if address has not changed!" show some changes, but OpenGL now randomely crashes the GPU.

Screenshots:

Everything is blue(da ba dee), water is now of the right color and we can see a bit of a wall.

Menu background now works correctly...but some other things disappeared.

Red screen is still there. Flickering still happens in menus and in the intro video.

Edit:
Did some testing with Vulkan.

Menu works almost perfectly (except for the rubbish text).

"You're that ninja." (Note : this is from an endgame save, hence the party is full)

Here's a screen of early ingame, for comparison.

Here's a skit. Upper half is not displayed.

And here's the world map with its bugged menu.

Lastly, an in-battle screen.



RE: Tales of Vesperia [NPJB90185] - Aquanaut14 - 12-28-2017

How goes the progress on this one?