RPCS3 Forums
X-Men - The Arcade Game [NPUB30320] - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Commercial Games (https://forums.rpcs3.net/forum-4.html)
+--- Forum: Playable (https://forums.rpcs3.net/forum-5.html)
+--- Thread: X-Men - The Arcade Game [NPUB30320] (/thread-162386.html)

Pages: 1 2 3 4


RE: X-Men - The Arcade Game [NPUB30320] - Ekaseo - 05-31-2014

Mod edit 2017-01-22
The game is now playable, see this and this post.

(01-18-2017, 02:06 PM)AlexVS Wrote:
(01-18-2017, 04:39 AM)legend80 Wrote: What libs do you have enabled? Any other setting maybe that can help me use the (faster) recompiler?
LIBs:
atxdec, jpgdec, l10n,
pamf, resc, rtc, sail,
sail_avi, spurs, sre
---
PPU - LLVM
SPU - ASMJIT
api - Vulkan
audio - Xaudio2


Im not sure if this is loadable or if it should go to intro. it displays a grey screen with almost 3fps. im sending a picture and log



RE: X-Men - The Arcade Game [NPUB30320] - ssshadow - 05-31-2014

A bunch of errors in that log... I think we should say that intro means that you can see something that at least somewhat resembles what a real ps3 would show.



RE: X-Men - The Arcade Game [NPUB30320] - Nickz - 06-08-2014

I think the game is responding to user inputs. The only way (for what i could see) to get these RSX textures is to press some random buttons on the GSFrame window. Maybe behind that gray screen the emu is actually playing the intro...



RE: X-Men - The Arcade Game [NPUB30320] - ssshadow - 06-08-2014

(06-08-2014, 08:23 PM)Nickz Wrote: I think the game is responding to user inputs. The only way (for what i could see) to get these RSX textures is to press some random buttons on the GSFrame window. Maybe behind that gray screen the emu is actually playing the intro...

It's the same shade of gray in that Marvel logo... So possibly it displays that texture incorrectly, perhaps try different resolutions?



RE: X-Men - The Arcade Game [NPUB30320] - Ekaseo - 06-08-2014

(06-08-2014, 08:35 PM)ssshadow Wrote:
(06-08-2014, 08:23 PM)Nickz Wrote: I think the game is responding to user inputs. The only way (for what i could see) to get these RSX textures is to press some random buttons on the GSFrame window. Maybe behind that gray screen the emu is actually playing the intro...

It's the same shade of gray in that Marvel logo... So possibly it displays that texture incorrectly, perhaps try different resolutions?

its the same gray screen with fps



RE: X-Men - The Arcade Game [NPUB30320] - Ru4slan - 12-28-2014

Game shows white screen with FPS.Game stop on moment and usage 100 % CPU.
Log:

Screen:




RE: X-Men - The Arcade Game [NPUB30320] - Ani - 02-07-2016

rpcs3-v0.0.0.6-454-gf66468f

PPU Interpreter 1
SPU Interpreter 1
DirectX 12

LLE modules:
cellFiber
cellSpursJq
cellSre
cellSysutilAvc2




Relevant stuff in the log
Code:
{rsx::thread} RSX: NV0039_OFFSET_IN: bad offset(in=0x2d90000, out=0x1400100), pitch(in=0x200, out=0x140), line(len=0x140, cnt=0x2d), fmt(in=0x1, out=0x1), notify=0x0
{rsx::thread} RSX: NV0039_OFFSET_IN: bad offset(in=0x2d90000, out=0x1400100), pitch(in=0x200, out=0x140), line(len=0x140, cnt=0x2d), fmt(in=0x1, out=0x1), notify=0x0

Full log attached

Also, these are too outdated:
http://www.emunewz.net/forum/showthread.php?tid=166338
http://www.emunewz.net/forum/showthread.php?tid=162386



RE: X-Men - The Arcade Game [NPUB30320] - tambre - 02-07-2016

(02-07-2016, 07:17 PM)Annie Wrote: rpcs3-v0.0.0.6-454-gf66468f

PPU Interpreter 1
SPU Interpreter 1
DirectX 12

LLE modules:
cellFiber
cellSpursJq
cellSre
cellSysutilAvc2




Relevant stuff in the log
Code:
{rsx::thread} RSX: NV0039_OFFSET_IN: bad offset(in=0x2d90000, out=0x1400100), pitch(in=0x200, out=0x140), line(len=0x140, cnt=0x2d), fmt(in=0x1, out=0x1), notify=0x0
{rsx::thread} RSX: NV0039_OFFSET_IN: bad offset(in=0x2d90000, out=0x1400100), pitch(in=0x200, out=0x140), line(len=0x140, cnt=0x2d), fmt(in=0x1, out=0x1), notify=0x0

Full log attached

Also, these are too outdated:
http://www.emunewz.net/forum/showthread.php?tid=166338
http://www.emunewz.net/forum/showthread.php?tid=162386

Instead of making a new thread, post to one of the older threads (if there are 2 threads for the game, post to the newer one, so they can be merged in "order&quotWink.



RE: X-Men - The Arcade Game [NPUB30320] - jmell - 01-10-2017

Hello,

I'm new here, this one seems to work now:

Fully playable, but bad sound.

0.0.1-4-2d9e02b Pre-Alpha

PPU Interpreter(fast)
SPU Interpreter(ASMJIT)
Vulkan
XAudio2

LLE modules:
cellSre
cellResc





RE: X-Men - The Arcade Game [NPUB30320] - ssshadow - 01-10-2017

Does the PPU LLVM recompiler work?