RPCS3 Forums
Terraria [BLES01938] - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Commercial Games (https://forums.rpcs3.net/forum-4.html)
+--- Forum: Playable (https://forums.rpcs3.net/forum-5.html)
+--- Thread: Terraria [BLES01938] (/thread-158739.html)

Pages: 1 2 3 4 5 6 7


RE: Terraria [BLES01938] - SerJons - 03-07-2014

Mod edit 2017-01-23 Now completely playable, see http://www.emunewz.net/forum/showthread.php?tid=176611



After a long (very long) loading and spam in the log:
[E: PPU [40] Thread (mstream-update) [0x009d0034]]: TODO: cellSpursEventFlagWait
[E: PPU [40] Thread (mstream-update) [0x009d00d0]]: TODO: _cellSpursSendSignal
Appeared intro:
http://i.imgur.com/G2flD1W.jpg



RE: Terraria [BLES01938] - leon112211 - 03-07-2014

More and more games starting to work now that is great!!!



RE: Terraria [BLES01938] - BlackDaemon - 03-07-2014

Hmm. Smile Btw, to solve "Multistream: mp3 failed to load MP3 codec" issue you need to dump this file from your PS3 "/dev_flash/sys/external/flashMP3.pic" and place it into rpcs3 directory (rpcs3\dev_flash\sys\external\flashMP3.pic).



RE: Terraria [BLES01938] - LittleGrejmer - 03-07-2014

I have propably complete dev_flash, but game stuck at loop of: cellSpursEventFlagWait, and _cellSpursSendSignal. It also opens white opengl window



RE: Terraria [BLES01938] - SerJons - 03-07-2014

(03-07-2014, 03:49 PM)BlackDaemon Wrote: Hmm. Smile Btw, to solve "Multistream: mp3 failed to load MP3 codec" issue you need to dump this file from your PS3 "/dev_flash/sys/external/flashMP3.pic" and place it into rpcs3 directory (rpcs3\dev_flash\sys\external\flashMP3.pic).

BlackDaemon, thank you, after adding flashMP3.pic problem "Multistream: mp3 failed to load MP3 codec" solved.

The game goes on if you wait.
http://i.imgur.com/DsnJ5HT.jpg
http://i.imgur.com/pLRekL0.jpg

(03-07-2014, 04:42 PM)LittleGrejmer Wrote: I have required files, but it stuck at loop of: cellSpursEventFlagWait, and _cellSpursSendSignal. It also opens white opengl window

LittleGrejmer, I solved this problem: all the files that are in the USRDIR carry to the main folder where TROPDIR and LITSDIR. Then run and long wait.



RE: Terraria [BLES01938] - ssshadow - 03-07-2014

Damn, I tested this game yesterday, but figured it was stuck in a loop of errors. Seems I don't have enough patience Tongue



RE: Terraria [BLES01938] - SerJons - 03-07-2014

So after a long wait will be a menu with graphical bugs.
http://i.imgur.com/L9xaHSI.jpg

And finally, the game responds to the buttons.
http://i.imgur.com/xvyQRu1.jpg



RE: Terraria [BLES01938] - ssshadow - 03-07-2014

Tried selecting "mstream-update" in the debugger and pausing that thread? Should make the rest of the game run a bit faster.



RE: Terraria [BLES01938] - SerJons - 03-07-2014

(03-07-2014, 05:16 PM)ssshadow Wrote: Tried selecting "mstream-update" in the debugger and pausing that thread? Should make the rest of the game run a bit faster.

?h, you're right so much faster. Thank you. Smile



RE: Terraria [BLES01938] - ssshadow - 03-07-2014

(03-07-2014, 05:22 PM)SerJons Wrote:
(03-07-2014, 05:16 PM)ssshadow Wrote: Tried selecting "mstream-update" in the debugger and pausing that thread? Should make the rest of the game run a bit faster.

?h, you're right so much faster. Thank you. Smile

About 40 fps here, although that's not entirely true since it pauses for 10 seconds after running for 1.

For me all graphics is over sized. What resolution and build are you running?