RPCS3 Forums
Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Commercial Games (https://forums.rpcs3.net/forum-4.html)
+--- Forum: Ingame (https://forums.rpcs3.net/forum-6.html)
+--- Thread: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] (/thread-156933.html)

Pages: 1 2 3 4 5 6 7 8 9 10 11


RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - rauldj - 01-26-2017

(01-26-2017, 01:05 PM)ssshadow Wrote:
(01-26-2017, 12:59 PM)rauldj Wrote: Welp, in these recent versions I can't get this Ar tonelico to boot anymore, it gets stuck in either the Gust or the Criware logo with no "red errors" whatsoever, just some "TODOs" like it was before.

This could always happen at random, it's loading or something. Just wait for a minute or three. Same problem with Atelier Rorona -> Ayesha. (They all use the same engine)

Yup, that was it, finally booted. It's a lot slower and I even think more prone to get "randomly" stuck than before, including that first load. I still can't get ingame but I'll keep trying.

EDIT: Perfomance loss starts on https://ci.appveyor.com/project/rpcs3/rpcs3/build/1.0.3553/artifacts and goes up to the latest one. On all the previous versions I can get to the screen scale menu within less than a minute.



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - ssshadow - 01-26-2017

Yeah looks like it broke. Keep trying a few times and if you (like me) can't get the intro to load open a bug on github with this information.

At the same time, this game was always very unstable (my theory is thread synchronization issues) and perhaps we are seeing a worsened symptom but not the cause with those mutex changes...

Tried two times: failed the first, worked the second. I don't think the game has regressed in any way, it's perhaps just randomly slightly less stable. Or not. The real bug(s) was and is still there.

[Image: 64940423.jpg]



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - rauldj - 01-26-2017

(01-26-2017, 04:32 PM)ssshadow Wrote: Yeah looks like it broke. Keep trying a few times and if you (like me) can't get the intro to load open a bug on github with this information.

At the same time, this game was always very unstable (my theory is thread synchronization issues) and perhaps we are seeing a worsened symptom but not the cause with those mutex changes...

Tried two times: failed the first, worked the second. I don't think the game has regressed in any way, it's perhaps just randomly slightly less stable. Or not. The real bug(s) was and is still there.

[Image: 64940423.jpg]

Well, I only got to main menu one time out of the 15 or so I tried. There's a real downgrade in performance starting on the version I talked about earlier but I don't know if that performance loss is considered a regression or not.



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - ssshadow - 01-27-2017

In Discord a person with a Kaby Lake i7 at 5 ghz couldn't run Atelier Totori at all (same engine) but it works ok for me. Point is the game is unstable, and it really looks like the speed of the computer affects stability, in other words thread synchronization issues.

Neko is working on a priority based thread scheduler, a wild guess is that this will make things much better.



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - rauldj - 01-27-2017

(01-27-2017, 12:23 AM)ssshadow Wrote: In Discord a person with a Kaby Lake i7 at 5 ghz couldn't run Atelier Totori at all (same engine) but it works ok for me. Point is the game is unstable, and it really looks like the speed of the computer affects stability, in other words thread synchronization issues.

Neko is working on a priority based thread scheduler, a wild guess is that this will make things much better.

Damn, that's fast as fuck... and yeah, I can't boot Totori either, so let's hope that scheduler will help.



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - ssshadow - 01-30-2017





RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - rauldj - 02-01-2017

(01-30-2017, 03:00 PM)ssshadow Wrote:

¯\_(?)_/¯

At least the pros are aware now: https://github.com/RPCS3/rpcs3/issues/2322



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - ssshadow - 02-02-2017

That bug has nothing to do with this game, it's been broken in this way since forever. But actually, if anything, I think it runs a little more stable now after those changes...



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - rauldj - 02-02-2017

(02-02-2017, 02:14 PM)ssshadow Wrote: That bug has nothing to do with this game, it's been broken in this way since forever. But actually, if anything, I think it runs a little more stable now after those changes...

Well, I was referring to the performance loss, not the random locks Confused.

I still can't get it to even boot most of the times on recent versions.



RE: Ar Tonelico Qoga : Knell of Ar Ciel [BLES01102] - ssshadow - 02-02-2017

(02-02-2017, 06:07 PM)rauldj Wrote:
(02-02-2017, 02:14 PM)ssshadow Wrote: That bug has nothing to do with this game, it's been broken in this way since forever. But actually, if anything, I think it runs a little more stable now after those changes...

Well, I was referring to the performance loss, not the random locks Confused.

I still can't get it to even boot most of the times on recent versions.

And I can almost consistently get to the first battle which was impossible before, never happened ¯\_(?)_/¯

I am certain there is some kind of concurrency issue going on here.

But yes, it is a little slower.