RPCS3 Forums
HHeretic v1.0 - Printable Version

+- RPCS3 Forums (https://forums.rpcs3.net)
+-- Forum: Homebrew (https://forums.rpcs3.net/forum-10.html)
+--- Forum: Ingame (https://forums.rpcs3.net/forum-12.html)
+--- Thread: HHeretic v1.0 (/thread-117328.html)

Pages: 1 2 3 4


RE: HHeretic v1.0 - Schemer - 12-10-2013

(12-09-2013, 02:44 PM)AlexAltea Wrote: So I guess your PS3 runs homebrews, right?

I don't know. I tried other PKG homebrews and they worked. But i can't run .elf files.

When i install hheretic.pkg from post 10, it created this dirs and folders:
Quote:/dev_hdd0/game/HERETIC01/
/dev_hdd0/game/HERETIC01/ICON0.PNG
/dev_hdd0/game/HERETIC01/PARAM.SFO
/dev_hdd0/game/HERETIC01/USRDIR/
/dev_hdd0/game/HERETIC01/USRDIR/EBOOT.BIN
And in game list appeared Heretic game icon labeled "HHERETIC - PS3". Run hheretic get error:
[Image: DSC_0022.png]
When i put HERETIC.WAD in "USRDIR" or in "heretic" folder on my usb flash, i get same error.
[Image: image.png]
P.S. sorry for my English.



RE: HHeretic v1.0 - BlackDaemon - 12-10-2013

Schemer, you probably trying to run it on 4.XX CFW, but this homebrew was (fake)signed for 3.55 CFW. You need to resign it, using tool, like TrueAncestor EBOOT Resigner.



RE: HHeretic v1.0 - Schemer - 12-10-2013

BlackDaemon, thank you. I not sure but in settings 3.55 and i can play game for CFW 3.55.



RE: HHeretic v1.0 - Josip 1793 - 12-24-2013

may be interesting for you Smile



RE: HHeretic v1.0 - Ekaseo - 12-24-2013

(12-24-2013, 11:26 AM)Josip 1793 Wrote: may be interesting for you Smile

i got ingame...



RE: HHeretic v1.0 - Chaoz27 - 12-24-2013

With the newest revision, I managed to get ingame!
The problem is, I don't know how the buttons are mapped to my keyboard/controller.
I would probably come further, if I knew the key mapping for the X or O Button, if those even exist. Undecided

EDIT: Ok the controls seem to work, but the game runs at 0.1 fps which doesn't help me much.





RE: HHeretic v1.0 - ssshadow - 12-24-2013

I got it to work in today's build! Put "HERETIC.WAD" in "\dev_usb000\heretic", and press circle, whatever key that is on a keyboard, when the game tells you to (press everything really fast, the game auto quits if you don't). You will eventually get to the main menu!

As usual, the game doesn't load the first time. So you start the game, and then start it again after it quits, without restarting the emulator. (The first time you will see "STOP 0x0" in the log)

├Ćnput is still a mystery. I have no idea which key is what, sometimes it seems like I have it figured out, only for it to fail the next time.

Somehow I got "in game" at the main menu, I think it is a demo mode. Screenshots in the imgur album.

[Image: 68r1UE7.png]

This is awesome.


EDIT: To late, I had loaded the thread earlier and didn't see the above posts Tongue



RE: HHeretic v1.0 - ssshadow - 12-24-2013

(12-24-2013, 01:07 PM)AlexAltea Wrote: Nice! Smile
Btw, have a look at this file to know the key bindings for controlling the PS3 games:
https://github.com/DHrpcs3/rpcs3/blob/master/rpcs3/Emu/Io/Windows/WindowsPadHandler.h#L42

Sweet, so the important bit is wasd for up/down/left/right, "L" for cross, and ";" for circle (which is shift+"," on Swedish keboard layout...)



RE: HHeretic v1.0 - Ekaseo - 12-24-2013

this thread should be moved to half-playable, i think



RE: HHeretic v1.0 - ssshadow - 12-24-2013

(12-24-2013, 01:11 PM)Ekaseo Wrote: this thread should be moved to half-playable, i think

I think so too, although I don't have the patience to verify at 0,1 fps, basic controls and gameplay should work. However there is no sound, so not fully playable.