NHL Legacy Edition [BLUS31540]
Started by digitaldude




37 posts in this topic
lynkred
Member


0
2 posts 0 threads Joined: Nov 2017
11-30-2018, 08:30 PM -
#11
Hi guys, 

My game alway turn around here
This post was last modified: 12-01-2018, 05:40 PM by lynkred.


Attached Files Thumbnail(s)
   
turbineseaplane
Guest


 
04-28-2019, 03:50 PM -
#12
So I've been testing this and it seems really close to working great for me.

I'm able to get 60fps and smooth play, nearly always, but there are occasional hesitations/pauses and I can't figure out why.
When it happens, the FPS doesn't dip, the whole thing seems to stall a bit and then keep going.

Sometimes it does go down to 50-ish fps in defensive zone also.

I've seen some mention of this might be caused by the game requesting or writing SPU threads at those times?
I've tried playing around with Safe/Mega/Giga to start with - can't get the game to boot with Giga though.

Love to have some tips if anyone has any.

I'm on 8700(non-k) and RX 580 8GB w/ 32GB System RAM
Kravicka
Member


0
153 posts 25 threads Joined: Aug 2017
05-17-2019, 06:47 PM -
#13
[Image: CwrhKKk.png]
[Image: 35v3py-2.png]
mondzi
Member


0
2 posts 0 threads Joined: May 2019
05-20-2019, 08:49 AM -
#14
Hi, I'm loving your work on RPCS3 and want to contribute at least with some reports.

With build RPCS3 v0.0.6-8147-8009e536 Alpha NHL Legacy Edition [BLUS31540] hangs after couple of seconds of gameplay with error in log: F {RSX [0x00c172c]} RSX: class std::runtime_error thrown: Unknown primitive type 64

.gz   RPCS3.log.gz (Size: 609.84 KB / Downloads: 17)

Also the audio stutters progressively worse and worse until it hangs.


My system:
CPU: Core i5 7600K
RAM: DDR4 16GB 3000MHz
GPU: GTX 1070 (419.35 driver)
OS: Win 10 (version 1809)

Please feel free to point me in the right direction if I'm missing something with the report.
This post was last modified: 05-21-2019, 02:12 PM by mondzi.
connorwalks
Member


0
148 posts 41 threads Joined: Feb 2019
05-23-2019, 11:31 PM -
#15
RPCS3-v0.0.6-8156-d616ce22 Alpha
Intel i9 9900K
16 GB 3000MHz DDR4
NVIDIA RTX 2080 (Driver 430.64)

Performance is OK but is still unstable. Crashes occur with collision (often times with the boards) like you can see at the end of the video when my player gets checked into the boards and disappears.




Attached Files
.7z   NHL Legacy Log.7z (Size: 440.84 KB / Downloads: 16)
Kravicka
Member


0
153 posts 25 threads Joined: Aug 2017
05-27-2019, 09:36 PM -
#16
(05-23-2019, 11:31 PM)connorwalks Wrote: RPCS3-v0.0.6-8156-d616ce22 Alpha
Intel i9 9900K
16 GB 3000MHz DDR4
NVIDIA RTX 2080 (Driver 430.64)

Performance is OK but is still unstable. Crashes occur with collision (often times with the boards) like you can see at the end of the video when my player gets checked into the boards and disappears.

Use SPU LLVM with Mega, didnt happen that to me on LLVM.. it did happened to me with ASMJIT. There will be still random crashes with RSX or access violations. Acess violation quite easy to trigger in be a pro mode every time in first game.
[Image: CwrhKKk.png]
[Image: 35v3py-2.png]
icyc
Member


0
3 posts 0 threads Joined: Nov 2018
06-12-2019, 01:36 AM -
#17
(05-27-2019, 09:36 PM)Kravicka Wrote: Use SPU LLVM with Mega, didnt happen that to me on LLVM.. it did happened to me with ASMJIT. There will be still random crashes with RSX or access violations. Acess violation quite easy to trigger in be a pro mode every time in first game.
I've got no issues so far on 0.0.6-8196-2bc0ea37 Alpha with those settings (SPU LLVM, Mega, Auto framerate)

Plays smooth and no errors (on stock 9900k)
This post was last modified: 06-12-2019, 01:43 AM by icyc.
mondzi
Member


0
2 posts 0 threads Joined: May 2019
06-14-2019, 06:59 AM -
#18
Today I've retested with build RPCS3 v0.0.6-8213-ac3982d2 Alpha NHL but it still hangs after couple of seconds of gameplay, this time with error:

F {RSX [0x0895408]} RSX: class std::runtime_error thrown: Unknown index array type 180

.gz   RPCS3.log.gz (Size: 617.02 KB / Downloads: 3)

My system:
CPU: Core i5 7600K
RAM: DDR4 16GB 3000MHz
GPU: GTX 1070 (430.97 driver)
OS: Win 10 (version 1809)
Kravicka
Member


0
153 posts 25 threads Joined: Aug 2017
07-20-2019, 05:27 PM -
#19
Random error, probably from not enough performance -> desync
[Image: CwrhKKk.png]
[Image: 35v3py-2.png]
turtleneckthomas
Member


0
18 posts 0 threads Joined: Oct 2017
10-30-2019, 08:29 AM -
#20
I'm seeing a large grey bar on the side using vulkan.  This doesn't occur with opengl.

Latest version of rpcs3.

[Image: mSZhYUz]


Forum Jump:


Users browsing this thread: 1 Guest(s)