GrantKaneRayman Legends [BLES01863]
Started by GrantKane




19 posts in this topic
GrantKane
RPCS3 Tester


0
2,671 posts 1,777 threads Joined: Aug 2017
08-21-2017, 08:58 PM -
#1
RPCS3 v0.0.3-3-a822d99 Alpha
Ingame with graphic bugs.
[Image: a7geFN1.jpg]
[Image: QEdTnGl.jpg]
This post was last modified: 09-24-2018, 11:31 PM by GrantKane.


Attached Files
.7z   RPCS3.7z (Size: 238.34 KB / Downloads: 55)
evilalex
Member


0
7 posts 0 threads Joined: Dec 2017
12-02-2017, 09:08 PM -
#2
Degrade in rpcs3-v0.0.4-2017-12-01-8f314c51_win64 !

Certain textures, such as main menu background and backgrounds in some areas started to flicker in both Vulkan and OpenGL.
Strict rendering or not, doesn't seem to matter anymore.

Seems to spam "E {rsx::thread} RSX: Blit request denied because the destination region does not fit!" error when runs via Vulkan.

Was previously playable in rpcs3-v0.0.3-2017-10-09-6d6b2812_win64 with Strict rendering enabled.
   

.gz   RPCS3.log.gz (Size: 261.4 KB / Downloads: 11)
evilalex
Member


0
7 posts 0 threads Joined: Dec 2017
12-20-2017, 12:14 AM -
#3
Playable again in rpcs3-v0.0.4-2017-12-18-de5dab35_win64 (didn't work properly with the above mentioned bug in all interim builds between this one and my previous post).

It still keeps spaming "blit request" error, and I also noted that it gives off a suspicious "E {rsx::thread} RSX: NV3089_IMAGE_IN_SIZE: Invalid blit dimensions passed" on startup.
However, the graphics no longer glitch visually. I tested one stage entirely, and found nothing missing or flickering.

Thanks for fixing this regression.


Attached Files
.gz   RPCS3.log.gz (Size: 2.11 MB / Downloads: 10)
torrente
Member


0
2 posts 0 threads Joined: Oct 2017
02-13-2018, 12:07 AM -
#4
(12-20-2017, 12:14 AM)evilalex Wrote: Playable again in rpcs3-v0.0.4-2017-12-18-de5dab35_win64 (didn't work properly with the above mentioned bug in all interim builds between this one and my previous post).

It still keeps spaming "blit request" error, and I also noted that it gives off a suspicious "E {rsx::thread} RSX: NV3089_IMAGE_IN_SIZE: Invalid blit dimensions passed" on startup.
However, the graphics no longer glitch visually. I tested one stage entirely, and found nothing missing or flickering.

Thanks for fixing this regression.

Big Grin  It did not last long.

In commit 3827 onwards there was regression.

Currently status Ingame

https://github.com/RPCS3/rpcs3/pull/3827
RPCS3_FAN
Member


0
42 posts 9 threads Joined: Dec 2017
02-13-2018, 10:00 PM -
#5
Sometimes the Picture stays black but you can move character. On Pause Menu you see the level Sad Any Solutions?
legend80
Member


0
120 posts 3 threads Joined: Aug 2017
02-14-2018, 03:04 AM -
#6
Confirmed the background is broken again. Just flickers like mad with Strict Rendering on.

Maybe submit a github defect, since it's a regression?

EDIT:
Looks like it was this commit actually:
https://github.com/RPCS3/rpcs3/pull/3772 by kd-11

Worked fine on this build: https://ci.appveyor.com/project/rpcs3/rp.../artifacts
Broken on the the next build: https://ci.appveyor.com/project/rpcs3/rp.../artifacts
This post was last modified: 02-14-2018, 06:46 AM by legend80.
RPCS3_FAN
Member


0
42 posts 9 threads Joined: Dec 2017
02-16-2018, 09:35 PM -
#7
On Strict Rendering Mode Rayman is working. Just background flickering but at least playable Smile
legend80
Member


0
120 posts 3 threads Joined: Aug 2017
02-17-2018, 02:21 AM -
#8
I know, that's what we said. The point is the game is broken and we know what build caused it.

Hopefully we can get this game back to being truly perfect again on current builds. For now, an old one is needed to play properly.
legend80
Member


0
120 posts 3 threads Joined: Aug 2017
04-08-2018, 12:03 AM -
#9
Logged issue in Github to get more traction:
https://github.com/RPCS3/rpcs3/issues/4412
evilalex
Member


0
7 posts 0 threads Joined: Dec 2017
Sad  05-31-2018, 06:25 PM -
#10
Can confirm that, unfortunately, the reintroduced issue still persists in rpcs3-v0.0.5-6882-87b510d5_win64 with the same "Blit request denied" error in the log as before.

UPDATE: Still no progress in rpcs3-v0.0.5-7024-cd59bc3d_win64, the game flickers the same way. No additional settings including "Force CPU Blit" influence the issue. The best that can be achieved is slowing the flickering a tiny bit.
The game is clearly NOT PLAYABLE in this regressed state, unless you want to break your eyes.

UPDATE 2: Despite a lot of work performed by kd-11 in "AAA fixes #4973", a PR that some have hoped should fix the issue, the same bug occurs without any changes in the most recent rpcs3-v0.0.5-7216-7915dcb2_win64 incorporating that PR. The game is still unplayable due to flickering.

It starts with:
E {rsx::thread} RSX: NV3089_IMAGE_IN_SIZE: Invalid blit dimensions passed
E {rsx::thread} RSX: Invalid framebuffer setup, w=0, h=0
Probably has to do with some initializing command failing.
This post was last modified: 08-18-2018, 01:44 PM by evilalex. Edit Reason: No progress, despite hope placed on a recent PR by kd-11


Forum Jump:


Users browsing this thread: 1 Guest(s)