Hello There, Guest! Register

the emulator wont run
#1
my laptop has windows 8.1 64 bit. i downloaded the latest version of the emulator and i got all the needed 64 bit dll files. below is picture of emulator folder:-

when i run the emulator i get this error message:-


how do i fix it?
Reply
#2
(01-08-2016, 02:29 PM)cns00 Wrote: my laptop has windows 8.1 64 bit. i downloaded the latest version of the emulator and i got all the needed 64 bit dll files. below is picture of emulator folder:-

when i run the emulator i get this error message:-


how do i fix it?

You need the redistributable package, as is listed on our Github page.

Since you're new, please also read the FAQ.
Please also see the playable games section and keep in mind, that most commercial games wont work.

You likely need to also obtain some files from your Custom Firmware PS3 through a FTP server, to have any chance of getting most games even to boot or maybe even display a couple first intros.

Please also remember, as you're on Windows 8, you won't be able to use the DX12 renderer, which currently is far better than the OpenGL renderer. You likely wont be able to see graphics for most games or the speed will be very slow.
Reply
#3
what do u mean by:-

You likely need to also obtain some files from your Custom Firmware PS3 through a FTP server, to have any chance of getting most games even to boot or maybe even display a couple first intros.

i installed the redistributable and the emulator started. i got the game terraria and in the emulator i said boot game and selected the game folder. i now see this:-


what do i do next? which files do i get and where do i put them? i read the faq. it doesnt mention what i need to do
Reply
#4
(01-08-2016, 03:26 PM)cns00 Wrote: what do u mean by:-

You likely need to also obtain some files from your Custom Firmware PS3 through a FTP server, to have any chance of getting most games even to boot or maybe even display a couple first intros.

i installed the redistributable and the emulator started. i got the game terraria and in the emulator i said boot game and selected the game folder. i now see this:-


what do i do next? which files do i get and where do i put them? i read the faq. it doesnt mention what i need to do

I don't understand what you don't understand. Could you explain what you don't understand exactly?

About LLE modules see this post.
You should probably also obtain flashATRAC.pic and flashMP3.pic from the PS3.

Also it probably wont be even worth trying to play or boot games with OpenGL, other than debugging purposes. OpenGL renderer, as I explained before, is very inaccurate and slow, and should hopefully be removed very soon.

Also, you should place the games in /dev_hdd0/game/, as you can probably see from the file structure of your PS3 filesystem through the FTP server. Disc games should also be placed in /dev_hdd0/game/, instead of /dev_bdvd/.

Here's also a small tutorial for how to copy the games over from your PS3.
Reply
#5
it's ok. i fixed it and i got the game to start. this is what i see:-


the game started ok and it showed the first few screens using 50fps. when it got to the screen in the picture them the fps dropped to 1.8fps, there are graphical glitches and sound became choppy

how come it ran perfectly in:-
https://www.youtube.com/watch?v=8DtMepv9uJU

in the video it uses dx12 for the graphics. for me i can use only openGL (there is only the openGL option in the graphics for me). how do i add the dx12 option?
Reply
#6
If you somehow missed it, DX12 is only for Windows 10.

Not that you should expect that any relevant game will run.
Reply
#7
(01-09-2016, 03:18 PM)cns00 Wrote: it's ok. i fixed it and i got the game to start. this is what i see:-


the game started ok and it showed the first few screens using 50fps. when it got to the screen in the picture them the fps dropped to 1.8fps, there are graphical glitches and sound became choppy

how come it ran perfectly in:-
https://www.youtube.com/watch?v=8DtMepv9uJU

in the video it uses dx12 for the graphics. for me i can use only openGL (there is only the openGL option in the graphics for me). how do i add the dx12 option?

Like sshadow mentioned, you'll need Windows 10 for DX12 and you'll also need DirectX12 feature level 11 compatible graphics card.
Reply
#8
my laptop is alienware 17, 32gb ram and an nvidia gforce gtx880m graphics card with 8gb ram

i am using windows 8.1. i am not in a hurry to upgrade to windows 10 because it still has issues

will the dx11 option be added to the emulator later on?
Reply
#9
(01-10-2016, 11:28 AM)cns00 Wrote: my laptop is alienware 17, 32gb ram and an nvidia gforce gtx880m graphics card with 8gb ram

i am using windows 8.1. i am not in a hurry to upgrade to windows 10 because it still has issues

will the dx11 option be added to the emulator later on?

Adding a DX11 renderer would be a big downgrade and would have no benefit over our current and future planned renderers. The only reasonable reason I'd see for the existence of a DX12 renderer is that Vulkan isn't out yet.
Ideally, I would like us to remove both the OpenGL and DX12 renderers in favour of a single Vulkan renderer, that includes all the benefits of DX12 with even more benefits.
Vulkan entered legal review during christmas and will probably released in a couple months.
Reply
#10
it would be better if all graphic renderers are added to the emulator so the person can choose one that best matches his/her machine

will the vulkan option in the emulator be available for windows 8.1?

how much longer will it take for the perfected emulator to be released? a few years have already passed
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)