Nier Replicant [BLJM60223]
Started by ssshadow




70 posts in this topic
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
03-09-2014, 01:57 AM -
#1
Game displays black gsframe with 2-3 fps. Also plays two short distorted noises, although it may just be some bug.

Here is the log: http://pastebin.com/XisdvnUN
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
02-11-2015, 10:26 PM -
#2
Goes further now, shows some textures in the RSX debugger, and maybe flashes a single white frame.

Had to pause some thread that looped forever on a spurs TODO. The game eventually stops at... spurs TODO's.


tambre
Guest


 
02-12-2015, 02:30 PM -
#3
(02-11-2015, 10:26 PM)ssshadow Wrote: Goes further now, shows some textures in the RSX debugger, and maybe flashes a single white frame.

Had to pause some thread that looped forever on a spurs TODO. The game eventually stops at... spurs TODO's.

I saw in the log that some files weren't found. Maybe that's the cause of it not going further?
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
02-12-2015, 02:46 PM -
#4
(02-12-2015, 02:30 PM)tambre Wrote:
(02-11-2015, 10:26 PM)ssshadow Wrote: Goes further now, shows some textures in the RSX debugger, and maybe flashes a single white frame.

Had to pause some thread that looped forever on a spurs TODO. The game eventually stops at... spurs TODO's.

I saw in the log that some files weren't found. Maybe that's the cause of it not going further?

No, the game has all files in a big archive that is found and read. For some reason it checks in other locations as well, but if I remove the big archive file it doesn't get as far as it does now. So missing files is not the problem.
BlackDaemon
Moderator
*****


2
844 posts 374 threads Joined: Aug 2017
02-02-2017, 04:02 AM -
#5
Tested on recent master build v0.0.1-9eba0ac5 (PR #2317). Crashes on loading screen. Make sure to decrypt .sdat file before running game. Corrected thread title, because japanese version is a bit different, comparing to global Nier.
Code:
F {rsx::thread} class std::runtime_error thrown: Invalid arguments (addr=0xcef1a000, size=0x0)
(in file C:\rpcs3\rpcs3\Emu\Memory\vm.cpp:375)

LLE used
Code:
- libadec.prx
- libat3dec.prx
- libatrac3plus.prx
- libatxdec.prx
- libl10n.prx
- libpamf.prx
- libresc.prx
- librtc.prx
- libspurs_jq.prx
- libsre.prx
ssshadow
Administrator
*******


4
2,490 posts 63 threads Joined: Aug 2017
02-02-2017, 06:40 PM -
#6
For the record it can display the intro video (perfectly) and attempt to go ingame with a small hack:¨
http://www.emunewz.net/forum/showthread.php?tid=176647
Blast Processing
Member


1
111 posts 21 threads Joined: Aug 2017
03-18-2017, 05:22 PM -
#7
This game goes in-game right now, although I wouldn't quite recommend playing it yet since the graphics are severely broken.


rudi4463
Guest


 
03-18-2017, 10:03 PM -
#8
how did you get past the invalid name screen?
Blast Processing
Member


1
111 posts 21 threads Joined: Aug 2017
03-19-2017, 12:37 PM -
#9
(03-18-2017, 10:03 PM)rudi4463 Wrote: how did you get past the invalid name screen?

I used a saved game
V731
Guest


 
04-02-2017, 07:16 AM -
#10
(03-19-2017, 12:37 PM)blastprocessing Wrote:
(03-18-2017, 10:03 PM)rudi4463 Wrote: how did you get past the invalid name screen?

I used a saved game

There is a better option - just copy any japanese text from the internet (for example, i have copied title of this game in jap from wiki its page).

Well, for me it's 8-14 fps, sound stutter. Everything is cool in cut scenes, but visuals glitch badly during play.

Also, how it come that register form on this site isn't secure (according to firefox at least)?

gtx 1060 (laptop)
i7 6700hq
16gig ram

sorry for my eng.


Forum Jump:


Users browsing this thread: 2 Guest(s)