RPCS3 Forums

Full Version: Metal gear solid peace walker random frame drops
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm getting random frame drops in metal gear solid peace walker running at 4k. I'm using game patch 1.0 and the latest version of rpcs3. I'm using a 3080ti gpu with a ryzen 5 5600x processor. I've seen people run this fine with worse specs so I'm not sure why I'm getting bad fps drops. It runs perfect for the most part just every 5 minutes or so the frame rate drops are really bad and lasts around 10 seconds then goes back to normal. This doesn't seem to be in any specific part of the game just happens completely randomly. Does anyone know how I can sort this? I've tried changing all settings but nothing seems to work. Any help would be appreciated, thanks.
I noticed you made 2 threads but in none of them there's a log file as an attachment, I'll approve this one so you know you have to add a log file
Anyone know how I can sort this? Really staying to bug me now I just can't understand what's causing it. The fps counter says its dropping to around 45fps then back to 60. I've got vsync enabled in nvidia settings. Tried disabling it and running vsync on rpcs3 and tried all the frame rate limit settings on rpcs3 too. I'm also getting screen tearing in all cutscenes across all games in rpcs3 but not in game. My tv is 120hz but I only use 60fps and have tried limiting frame rate to 60 in both nvidia and rpcs3 settings. Cpu usage is about 40% is this normal? I have reshade installed and thought that might have been causing it but uninstalled it and still the same. Another thing was turning of nvidia low latency mode as that can effect cpu performance but that didn't change help either. This literally makes no sense why the frame rate is dropping so badly on a game that's meant to be easy to run.
Guess I'll try a different forum then
> Doesn't complete the thread with a log file as requested and as mentioned in the support guidelines
> Complains it has no answer

The problem isn't the forum, it's you. Thread locked.