RPCS3 Forums

Full Version: Final Fantasy XIII-2 [BLUS30776]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So I finally finished playing Final Fantasy XIII-2 on the emulator (I finished it multiple times on my PS3) and this is not worthy of a proper compatibility report, this is more of a report of what I encountered in terms of issues and more. Please do not hesitate to provide me with tips on how to debug this.

General status: Ingame

As I just mentioned, I was able to finish the game but I encountered two major problems.

The first major problem is that without any custom settings, you will not be able to play this game. It will probably hang after chapter one when the meteorite arrives. See https://github.com/RPCS3/rpcs3/issues/8860.

This also contains spoiler for the game, so beware.

The very first glitch I encountered were broken shadows. I reported an issue. Sometimes they are barely visible but they may be quite annoying in other levels. They do not have any effect on how playable it is.

[Image: 117498725-75134480-af7a-11eb-90f5-95c0b2c3e7f0.png]

[Image: 115997851-fe269500-a5e4-11eb-860c-3e0e8ebdf8af.png]

Historia crux gate matrix view not working properly

Portals are overlapping in the gate matrix, which is the default, overview and it is possible to "get stuck" on them, so you can not proceed further, this happens as early as chapter 2. Fortunately there is another view available which is accessible by pressing L1. It would be game breaking and impossible to finish when the other view would not work. This is certainly a significant glitch.

[Image: JSxtnb4.png]

Transparent Lightning

In the Vile Peaks you will encounter Lightning for a brief time. Unfortunately she seems to be rather transparent. You can see her hair through her head and from the distance her armor is visible through her skin. Lightning only appears to be transparent for a short time, so I could not grab a screenshot of this yet.
This is a very minor glitch.

Serious glitch: The whole screen fades to white in the New Bodhum dreamworld

When you finish the Void Beyond and get impaled by Caius, you will get sent to the New Bodhum dreamworld level. Right now it is barely playable because the screen starts to fade to white after a few seconds, but entering a battle or speaking with someone resets it. Unfortunately it will fade to white again and again, so you have to basically play through this level blind. Additionally it seems like this is not purely white, the gloom increases to insane levels. You can still see the speech bubbles, subtitles, minimap and some paradox effects around Vanille.
You can not reasonably finish this level but I did using the minimap.

Gloom seems too intense

Some levels use incredible amounts of gloom, but unfortunately you get blinded by this and most of the screen is white. This is not serious as it happens in very few areas and unlike the issue above, you can still see where to go.
The Ashensand in Oerba is especially bad.

[Image: pO8acmg.png]

And last but not least,

Performance of the game

Overall the performance seems to be worse than I experienced it on the PS3, but it is very important to mention that it may be my hardware. My Ryzen 1600af, 8 gigabyte of DDR4 RAM and my rx 570 (OC version) are not the fastest players in the market.

I noticed poor framerate (15-25 fps) in quite a few areas, especially Archylte Steppe and Academia. Both have rainy variants, and I think it is the rain which causes the lag. But the presence of NPCs seem also an issue because the Nomad Camp full of people at rain is horribly laggy. The Clearwater Marshes are also not pleasant while it is raining but it seems to be better than the Nomad Camp.

In the very beginning of the game the framerate may drop when you approach complex geometry like Etro's Gate.

But there was one positive thing I noticed, on the PS3 the teleport animation in the Archylte Steppe when you touch one of these red cactuar statues was incredibly choppy, but it is just fine in RPCS3.


If you really want to, it is playable. It will take some time and effort before it reaches the official status of playable.
So I tested a bit more, progressed further and tried other stuff. And I got some new screenshots for you all.

Re: Historia crux gate matrix view not working properly

Unfortunately I am now stuck because of the historia crux glitch I mentioned. I explored some of the paradox endings and when defeating Atlas again, it took me to another portal and it is not possible to switch the view from there, so now I can not go back and close the gate. It is not possible to 100% this game right now.

Re: Transparent Lightning

Seems like it happens to Noel, too when you do the paradox ending in which you go with Lightning in the New Bodhum dreamworld. It happened too fast and I could not grab a screenshot here unfortunately. This is something incredibly minor though.

Save icon does not vanish after saving

This is something annoying and I can not reproduce this reliably. After auto saves, the save icon may not vanish. Pause the game, save manually, it will vanish in most cases. I forgot to mention that in my original post and I even took notes about every glitch I encountered before posting that. Sorry about that.

Re: Gloom seems too intense

This will probably need further testing. It seems like the gloom is too intense in almost all areas. It is too bright, but the only really annoying thing is the occurance in the Ashensand in Oerba.

In "Original PS3"/"RPCS3" screenshot threads I definitely saw a difference in contrast in general. I do suspect contrast and color balance here, the game seems to make heavy use of it.

Re: The whole screen fades to white

https://imgur.com/a/VsTYJiL I posted some screenshots in there.

[Image: dGpHKrF.png]

When the whole screen fades to white, it really looks like it is the gloom. The paradox effects "override" it somehow it seems. I picked the picture with the strongest visible effects for embedding.

As I said, the level is playable if you want it to be but it is incredibly annoying to finish. Still not reasonably playable unfortunately.

General debugging

I tried to debug random settings that might fix this gamebreaking historia crux thing I am currently stuck on, but unfortunately none of it worked. This included:

  • Panicking
  • Setting the SPU Decoder to ASMJIT
  • Setting both the PPU and SPU Decoder to Interpreter (yes, it was horribly slow)
  • Changing from Vulkan to OpenGL
  • Playing with the frame limit for some reason

Yes, I made sure to reboot the game every time I changed anything. I experienced frequent cache corruption (is that even the right word?) for some reason, I got weird ingame shader errors and had to rm -rf (yes, I know what I am doing) $XDG_CACHE_HOME/rpcs3. The ArchWiki rescued me yet again. I still got random segfaults while compiling the PPU/SPU stuff though. So far this only happened with this particular game.

I also recompiled RPCS3 to use the latest git version (0b9e4ffe5 -> fe17c8302). I would really appreciate any help debugging the gamebreaking issues. And yes, I should probably create issues for them but I have no idea how to even debug this. I am not a dev, but nothing gets added to the log when I try and reproduce a problem. For some reason the game freezes when I try and do an RSX capture. I do not know if this is intended. The capture still gets created but I am worried that it might be incomplete or corrupted.
Hi, I tried to get to the end like you did, but seems the weird crux bugs made it unwinnable for me.

So I had the same issue with portals over lapping, the game is unable to do diagonal routed paths so spawns on top instead, like you said using alternate view allows you to navigate.

However I also hit a second problem, when I went back to 005AF to open all the gates the story started again in the areas as if I had closed the gate, but gate wasnt closed, regardless I played through it again and was able to proceed.

I then played through chapter 2, and 3, and I beat the boss in the steppe to weaken the big flan, but when I went back to 300 AF to fight the weakened flan it reset the area as if the gate was closed. So I only had the option of beating the flan at full strength. Going back to the steppe however did not reset that area, so basically I couldnt trigger the step again to weaken the flan, since I am not powerful enough to beat the flan at full strength as thats designed to be done post game, my playthrough ended at that point.

In addition to this there is rendering issues on the mog clock and stagger gauge box. Not fixable by enabling all the safe/accuracy options.