RPCS3 Forums

Full Version: Version Of RPCS3 That Uses Opengl 4.0?!
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Guys,
I downloaded The latest version of RPCS3, which is v0.0.14-11536-838cbe18.
it didn't work for me i thibk because i don't have Opengl 4.3.
i was thinking if i use an old version that uses Opengl 4.0. which my intel HD graphics 4000 supports. it may work for me.
could anyone tell me which version to try?!
No, you need to buy a proper GPU.
You can install a Linux distro with latest Mesa drivers so you can use Vulkan (albeit limited), but not OpenGL since that's a 4th gen GPU.
(01-11-2021, 07:27 PM)Ani Wrote: [ -> ]No, you need to buy a proper GPU.
You can install a Linux distro with latest Mesa drivers so you can use Vulkan (albeit limited), but not OpenGL since that's a 4th gen GPU.

Will it run The House Of The Dead 4 and God Of War?!
You never said what CPU you have, but I wouldn't bother. A proper GPU with Vulkan support can be found for $50, get one.
(01-11-2021, 10:20 PM)Ani Wrote: [ -> ]You never said what CPU you have, but I wouldn't bother. A proper GPU with Vulkan support can be found for $50, get one.

My PC Specs Are:-
CPU : Intel Core I7 3770k at 3.5 GHz, Has Intel HD Graphics 4000.
Ram: 2 x 4 GB.
Yeah, 3rd Gen iGPU won't even work, buy a GPU as I mentioned
(01-12-2021, 09:57 AM)AllooshBey Wrote: [ -> ]
(01-11-2021, 10:20 PM)Ani Wrote: [ -> ]You never said what CPU you have, but I wouldn't bother. A proper GPU with Vulkan support can be found for $50, get one.

My PC Specs Are:-
CPU : Intel Core I7 3770k at 3.5 GHz, Has Intel HD Graphics 4000.
Ram: 2 x 4 GB.

Get a cpu at least i7-6700 and graphics card at least gtx 1050 ti.
3770K to 6700 is an awful upgrade recommendation... keeping the CPU will be fine depending on what they want to play. GPU doesn't have to be at least 1050 Ti, just something modern that supports Vulkan, 1050 is fine as well.
Hey,

I am using a MacBook Pro with parallel desktop windows 10 and I have did everything and downloaded as it mentioned on social videos and websites, but when I am trying to boot a game the white screen show up with some errors failed and fatal errors I have downloaded the latest emulator with latest ps3 software updated.

Errors showing like that:


E {RSX [0x0000000]} RSX: OpenGL: initialization of glTextureBarrier failed.
E {RSX [0x0000000]} RSX: OpenGL: initialization of glTextureBarrierNV failed.
E {RSX [0x0000000]} RSX: OpenGL: initialization of glMemoryBarrier failed.
E {RSX [0x0000000]} RSX: OpenGL: initialization of glDispatchCompute failed.
E {RSX [0x0000000]} RSX: OpenGL: initialization of glDepthRangedNV failed.
E {RSX [0x0000000]} RSX: OpenGL: initialization of glDepthBoundsdNV failed.
F {RSX [0x0000000]} SIG: Thread terminated due to fatal error: Unknown context dma 0x0
(in file D:\a\1\s\rpcs3\Emu\RSX\gcm_enums.cpp:1176[:22], in function to_context_dma)


MacBook Specs:
MacBook Pro (16-inch, 2019)
Processor; 2.4 GHz 8-Core Intel Core i9
Memory: 32 GB 2667 MHz DDR4
GPU: AMD Radeon Pro 5500M 8 GB

Parallel desktop with:
Processors is 16
Memory 16GB
You need to install Windows or Linux natively.