RPCS3 Forums

Full Version: Amplitude [NPUB31810] - Freezing even in windowed mode.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello everyone,

So, this used to be my favorite PS3 game and I checked to see if it was playable on PC, turns out, its playable. However, I'm getting emulator freezes before finishing the first song. Tried with every ship in any of the songs available at game start.

Turns out, it's a known issue where the solution is just to play it windowed. But the freezes still occur in windowed mode.

I'm trying to play 720p windowed mode 30fps. Only setting that I changed was GPU to use Vulkan (and some gui stuff to see cpu usage).

My specs:
i7-7700k - 4.5ghz turbo mode
16gb ddr4 2400mhz
RTX 2070 Super

RPCS3 version 0.0.12-10959-046923d9 Alpha.

P.S.: Sorry for bad english.
So, I wanted to write an update since I resolved the issue on my own. I had to reinstall my operational system for work reasons and even after that I still got the same problem, so it wasn't some windows error or anything.

I'm not very knowledgeable with programing and debugging, so I fixed it with trial and error. What I mean is, I tried changing configurations one by one and testing, some broke the game (crashing as soon as it started) and others improved the time between freezes. Finally, I got one configuration that got me no freezes during the campaign (13 songs one), the emulator ended up freezing when it got back to the menu but managed to play the whole game without it and therefore made it playable (at least for me). Also, I played for quite a while after that with no other freezes.

What I changed (not listing settings I left at default):

CPU tab
-Preferred SPU Threads: From auto to 6
-SPU Cache: from enabled to disabled
-Enable thread scheduler: from enabled to disabled

GPU tab
-Renderer: from OpenGl to Vulkan (as recommended by the wiki)

After those changes I was able to finish one song. Seeing that as a success I changed the resolution from 720p to 1080p and framerate from 30fps to 60fps. Then, I proceeded to play the whole campaign.

I must remember that those are the configurations that worked best for my system, but probably isn't the most compatible configuration out there, so it might not work for you.

My rig:
i7-7700k - turbo boost enabled
2x8 DDR4 2400mhz
RTX 2070 Super