RPCS3 Forums

Full Version: Update 0.0.11-10792 Makes Lego Dimensions Crash Past Press Start Screen
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
One of the updates of RPCS3 called 0.0.11-10791 has broken Lego Dimensions where you can't get past the Press Start screen. Once I Press Start it completely crashes the game and the emulator with this error:


Code:
p, li { white-space: pre-wrap; }

F {PPU[0x1000016] Thread (NuDLCManager::UpdateRequest) [0x01bc518c]} VM: Access violation reading location 0x0 (unmapped memory)


This happens from version 0.0.11-10791 and every other version after that. Here is the regression that messed up Lego Dimensions:


Build Date: 23 days ago (2020-08-27)

Online/Matchmaking support: https://github.com/RPCS3/rpcs3/pull/8663

The latest version that works without a crash after pressing the start button is version 0.0.11-10790. So something you guys added or removed after version 0.0.11-10790 makes Lego Dimensions unplayable past the Press Start screen.


Any help would be greatly appreciated, thanks! Big Grin
I found out what causes Lego Dimensions to crash when you push the start button at the main title screen. For some reason the version 0.0.11-10791 update has broken RPCS3's ability to have a working simulated PSN network. Because when I set the PSN Status setting in the Network tab to disconnected and turn off the Network Connection by setting it to Disconnected the game works fine past the Press Start screen. So that update must have screwed up how RPCS3 sets up a simulated PSN network. Also if I try to use the new option of RPCN it gets past the press start screen but then hangs constantly loading on the main title screen. So the only thing that fixes this is having the internet connection and PSN disconnected from RPCS3.

This still happens on the latest update of RPCS3, version 0.0.12-10972.

Pull request SPU: Fix extremely rare bug of GETLLAR #9011.

https://github.com/RPCS3/rpcs3/pull/9011

If you guys could fix this rather strange bug with the simulated PSN Network then that would be great. The game runs fine but I have to be disconnected from the PSN Network. Which means I can't download any DLC until this is fixed. I can revert to an older 0.0.11-10790 version to install DLC, but I think this bug should be addressed and fixed before it screws up any other games in the future. Thanks!