RPCS3 Forums

Full Version: Demon's Souls error: Verification failed.
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello, I'd like to preface this by saying that Demon's Souls was running perfectly until this afternoon. Here's what happened.
I'm running windows 10, and my computer meets all requirements sfaik. it's not been a problem before. I'm sorry for the lengthy setup here, but hopefully it will be helpful. The specific error will be beneath that.

At some point, I needed to attach a printer to my PC, which is always a hassle for some reason, but i didn't want to reboot because i was still playing the game, i figured i could just attach it print what i needed to print and be on my merry way. This was naive. In the process, my computer eventually become unresponsive, but i was able to open the task manager and I killed rpcs3 thinking whatever nonsense was happening might go more smoothly without a program that eats 90% of all resources. Finally I logged out and rebooted, but the computer hung on the "rebooting" screen for like ten minutes so i gave up and held down the power button until it turned off and i turned it back on. Printer works fine now.

When I run Demon's Souls now, it freezes after it does the check for trophies.
The error it gives me is
Quote:"F {PPU[0x1000019] Thread (SLSession) [0x01d30258]} class std::runtime_error thrown: Verification failed:
(in file C:\projects\rpcs3\rpcs3\Loader\PSF.cpp:116)"

The directory C:\projects does not exist and never did.
I tried resetting the directories to their defaults, downloading and replacing the version of rpcs3 i was using with the latest one, and starting other stuff to see if they threw the same error, which they did not, as well as clearing the cache.
I was hoping that error would be enough to diagnose the problem, if not please let me know what. I'm not completely tech illiterate, but I don't quite know what this error means.
Probably corrupted savedata. Move your savedata elsewhere and try again..

Also, C:\projects does exist on the build environment, it's not relevant whether it exists on the end user's system or not.