RPCS3 Forums

Full Version: Intel HD 4600 stuck at compiling shaders
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
[attachment=15472][attachment=15472][attachment=15472][attachment=15472]Hi everyone,

New to rpcs3 and trying to get it going on a retro pc console. Unfortunately all 4 games I tried all end up with a black screen with Compiling Shaders message at bottom left of screen. I've confirmed the games work on another machine with Nvidia videocard.

Read the Quickstart Guide. I've read it. It says Intel cards could be problematic in one place, but also says any card with OpenGL 4.3 or later should work. Intel HD 4600 supports OpenGL 4.3

Make sure you're using the latest RPCS3 build. I am using RPCS3 v0.0.6-8536-b0d0f51d Alpha | Firmware version: 4.84

Check if your drivers are up-to-date. Latest win64_15.40.42.5063 drivers 

Check if your System matches RPCS3's requirements.  4 core Intel® Core™ i7-4770S CPU @ 3.10GHz | Intel HD 4600 | 8 GiB RAM | OS is Windows 10 64 bit, latest updates. 

Test with Interpreters too. Tried with interpreters too, result was the same - black screen, compiling shaders

Test with both Renders. Intel HD 4600 supports only OpenGL

Pack up your log files. Logs have been attached

Would appreciate any help! 

Please do not suggest I use try under Linux, I am using a Windows based front-ends for my emulation and everything is set up. I've seen in some older threads that Intel HD video used to work with RPCS3 in v0.0.5-xxxx-xxxxxxx, so if it ain't working now, then some commit broke it. If determining the last version where it worked is what it takes, then I would do it, as long as some dev is eager to thinker and find which commit broke the Intel HD compatibility.

Also please do not suggest I upgrade my video card. This retro pc machine I have is USFF/USDT and only has MXM slot for MXM 3 A type card. As u may know, those do not exactly sell in stores, only option is 2nd hand in ebay where most cards are really old and weaker than HD 4600, the ones that are worth upgrading cost $250+. Not to mention it's not guaranteed that the video card would actually work (manufacturer mainboard whitelisting)


Thanks in advance again!
·E 0:00:41.355741 {RSX Decompiler Thread} RSX: Failed to compile shader: ERROR: 0:121: 'tex00' : undeclared identifier
ERROR: 0:121: 'texture' : no matching overloaded function found (using implicit conversion)
ERROR: 0:121: 'process_texel' : no matching overloaded function found (using implicit conversion)
ERROR: 0:121: 'assign' : cannot convert from 'const highp float' to 'inout 4-component vector of highp float'

Known Intel driver bug. Intel drivers are not supported because they're too bad and don't comply with standards, specially the OpenGL ones.
https://github.com/RPCS3/rpcs3/issues/6199

Your only options as it stands are
- Using Linux with MESA
- Finding an AMD/NVIDIA card
- Using an older build previous to implementations that don't work on Intel drivers

kd-11 already gave up trying to workaround these driver issues because he plugs a hole and a new one appears, and this is something that's on Intel to fix, not on applications to try to come up with several workarounds and hope their drivers behave
Thanks for your reply Ani. Just heads up for anyone else that hit this like I did. I found the last working RPCS3 version for Intel HD 4600 (possibly the others HD graphics as well). It is rpcs3-v0.0.5-7607-25b8a425_win64. Ironically, the commit that broke it was made on Christmas, nice gift from kd-11 to us Intel HD gamers out there Smile

More heads up - I tried ALL Intel HD drivers for my 4th gen, including such from 2013 and also modded ones. The new implementation of RPCS3 would not work with any, always the same error from the log.

Linux is not viable for me as all my front-ends are based on Windows, but would appreciate if a Linux enthusiast tries the MESA drivers Ani mentions and share feedback here.

Cheers!

Was curious, so I wanted to take a look at the MESA drivers everyone talks about, it appears the link is dead: https://01.org/linuxgraphics
https://mesa3d.org/

Again, nothing is broken on RPCS3 side, Intel drivers just can't comply to specs, the syntax on RPCS3 is perfectly valid.

Starting on Skylake, Intel drivers support Vulkan and those at least can go Ingame and don't have issues with shader compiler syntax and whatnot, that's more of an issue on 4th gen where you're stuck with bad OpenGL support.
I've just ordered a k610m MXM card and hopefully would be able to get it running and more importantly have it running latest version of rpcs3 which Intel HD graphics no longer can. Here are the specs if anyone wants to comment: https://www.notebookcheck.net/NVIDIA-Qua...902.0.html
Unfortunately I received faulty k610m card, but managed to get my hands on Radeon HD 7650A, which is the default MXM video card that this HP machine is being offered as when was new. So the OpenGL issue is no more, I am able to run games on latest version of the emulator. However, this card does not support Vulkan, so my question is: how important is Vulkan for PS3 emulation? Would there be titles that would ONLY run on Vulkan vs. OpenGL? Or all games should be playable on both, but performance would be the differentiating factor?

P.S. If there is a modded VBIOS or modded drivers for Radeon HD 7650A, I would appreciate any help. I read here (https://www.amd.com/en/technologies/vulkan) that Vulkan is supported on HD 7730 and up, so maybe there is a hack for 76xx series?

Thanks!
Vulkan is quite important for performance. All titles should work in both renders, albeit slower on OGL. If there are discrepancies between the two renders, they can be reported as the intention is to have both on the same level of support.

No idea about trying to force Vulkan with a modded VBIOS.