RPCS3 Forums

Full Version: Demon souls not working
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
So i was trying to run demon souls but it started giving me errors , i tried it once some time ago and it worked but now with the same pc it doesnt and i cant figure out why
At first it was crashing but i fixed that and now it just stays white the game doesnt start , i tested OpenGL and Vulkan but still doesnt work
I'll Attach the log and prtscreen of what it looks like

[Image: Desktop%20Screenshot%202018.11.05%20-%20...55.98.png#]
[Image: Desktop%20Screenshot%202018.11.05%20-%20...52.27.png#]
[Image: Desktop%20Screenshot%202018.11.05%20-%20...47.83.png#]
Try with the build from this Pull Request
(11-05-2018, 02:21 PM)Ani Wrote: [ -> ]Try with the build from this Pull Request

How do i do that?
(11-06-2018, 09:52 PM)Ani Wrote: [ -> ]Direct build link is https://ci.appveyor.com/api/buildjobs/w9...5_win64.7z
Well the game opens now but instantly shuts down after some seconds
I attached the log
There is no attached log in your post
(11-08-2018, 06:23 PM)Ani Wrote: [ -> ]There is no attached log in your post

i added the log now , forgot to add attachment
Looking at your log, this may either be:

1. You have some cache files in the virtual PS3 cache partition (dev_hdd1) which are making the game get stuck. Open dev_hdd1 folder (note: dev_hdd1, NOT dev_hdd0) and delete everything inside it. On a real PS3, the cache partition is always mounted empty whenever you run a new game, but RPCS3 still doesn't clean it.

2. If the above doesn't work, you may be affected by a regression regarding CPUs with 4c4t. In this case, you'll need to use an older build. If it doesn't work on the build I pointed to after trying step 1, try the following older build:
and if that one still doesn't work, this one should:
I think I figured out a way to prevent the application from crashing after launching it. To do that, you need to enable the debug menu in the GUI Config folder, open CurrentSettings and scroll down until you see '"showdebugtab" and set it to "true" but without the quotation. After that, open RPCS3 config and go to the debug tab and check both Accurate GETLLAR, PUTTLUC, and Hook static functions then save. Done. Hopefully this method will work and helps.