RPCS3 Forums

Full Version: Demon`s Souls HP spectre x360
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi there,
I`m trying to run Demon`s Souls on a I5 8250U notebook with HD620 IGPU.
I tried Open Gl and the game starts. But when entering the Tutorial the textures somehow aren`t displayed correctly. It`s all grey and buggy. Only if I turn around and look in the air textures are displayed normally.
I tried many different config options but nothing changes.

I  the beginning i tried Vulcan but it kept crashing during startup giving me fatal error message.

After updating my graphics driver via device manager vulcan option is gone from menu.

any suggestions or is my cpu too weak for running the emu?

The "grey" textures you're describing isn't a bug, seems like you're not waiting enough time for the shaders to compile.

Intel Drivers are bad, they will cause you issues and they're not really supported. Intel needs to fix them.
If Vulkan doesn't show up on Render list, then use DDU and fully reinstall your GPU drivers.