RPCS3 Forums

Full Version: BioShock 2 [NPUB30392]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
RPCS3 v0.0.5-7123-c5c0f68b3 Alpha | HEAD
Ingame.
[Image: pdsfbia.jpg]
[Image: EfKajtR.jpg]
RPCS3 v0.0.8-9545-16bbd938 Alpha | HEAD | Firmware version: 4.85
Intel® Core™ i9-9900KF CPU @ 3.60GHz | 16 Threads | 15.91 GiB RAM | TSC: Bad | AVX+ | TSX




Operating system: Windows, Major: 10, Minor: 0, Build: 18363, Service Pack: none, Compatibility mode: 0
·! 0:00:00.000000 RSX: Found vulkan-compatible GPU: 'GeForce GTX 1070' running on driver 441.87.0.0

stats: playable


ingame stable at 29 to 30fps all the time.

it's fine and no crash or freeze at all , also needs WCB


log file and screenshots in Attachment
Ingame

Game's regressed, not playable anymore crashes with error:

F SIG: Thread terminated due to fatal error: Assertion Failed! Vulkan API call failed with unrecoverable error: Device lost (Driver crashed with unspecified error or stopped responding and recovered) (VK_ERROR_DEVICE_LOST)
(in file D:\a\1\s\rpcs3\Emu\RSX\VK\vkutils\sync.cpp:200[:5], in function wait_for_event)
(in file D:\a\1\s\rpcs3\Emu\RSX\VK\vkutils\shared.cpp:107[:24], in function die_with_error)

Tried default config, disabling fsr, testing it without vsync, I usually just increase the internal resolution and enable vsync, for this was the same.

Game simply refuses to work after a while, it's just crash, after crash, after crash, crashes the whole emulator too...

Tried with write color buffers on & off, didn't make a difference, I don't think it's needed anymore.

Either way the game crashes too much for it to be considered playable, the game's performance is way too erratic as well, bounces back and foward between 25-30.

Manage to "snag" a couple of screenshots, though.  Big Grin

RPCS3 v0.0.18-12802-3c7ada8e
(09-21-2021, 10:32 PM)Wolfinston85 Wrote: [ -> ]Ingame

Game's regressed, not playable anymore crashes with error:

F SIG: Thread terminated due to fatal error: Assertion Failed! Vulkan API call failed with unrecoverable error: Device lost (Driver crashed with unspecified error or stopped responding and recovered) (VK_ERROR_DEVICE_LOST)
(in file D:\a\1\s\rpcs3\Emu\RSX\VK\vkutils\sync.cpp:200[:5], in function wait_for_event)
(in file D:\a\1\s\rpcs3\Emu\RSX\VK\vkutils\shared.cpp:107[:24], in function die_with_error)

Tried default config, disabling fsr, testing it without vsync, I usually just increase the internal resolution and enable vsync, for this was the same.

Game simply refuses to work after a while, it's just crash, after crash, after crash, crashes the whole emulator too...

Tried with write color buffers on & off, didn't make a difference, I don't think it's needed anymore.

Either way the game crashes too much for it to be considered playable, the game's performance is way too erratic as well, bounces back and foward between 25-30.

Manage to "snag" a couple of screenshots, though.  Big Grin

RPCS3 v0.0.18-12802-3c7ada8e
Restest now.
Nah, sadly still crashes...

Same message too... I think?  Tongue

F SIG: Thread terminated due to fatal error: Assertion Failed! Vulkan API call failed with unrecoverable error: Device lost (Driver crashed with unspecified error or stopped responding and recovered) (VK_ERROR_DEVICE_LOST)
(in file D:\a\1\s\rpcs3\Emu\RSX\VK\VKQueryPool.cpp:49[:4], in function poke_query)
(in file D:\a\1\s\rpcs3\Emu\RSX\VK\vkutils\shared.cpp:107[:24], in function die_with_error)