RPCS3 Forums

Full Version: Final Fantasy XIII-2 [NPUB31083]
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Final Fantasy XIII-2 [NPUB31083]

RPCS3 0.0.3-3-170a95f Alpha

Intel i7-5820K
GTX 1080 - Current drivers

White screen and then nothing else. Tried OpenGL and Vulkan with all combinations of SPU/PPU types.
Tested on RPCS3 v0.0.5-6601-ee0fe28dd Alpha


- CPU:
[Image: QXt3fBQ.png]

- GPU:
[Image: Hxsn03i.png]

[Image: btRJU6S.png]

Reason: Crash after new games!

LOG File:

I fixed your version identifier, commit must be in the post so our script can pick it up
Oh ok! Thank you Mod!
Re-tested on RPCS3 v0.0.5-6976-c776ff502 Alpha


[Image: btRJU6S.png]

[Image: zBywgvK.jpg]

[Image: kulIkFo.jpg]

[Image: THcEb1f.jpg]

Goes ingame, because it's only work on OpenGL so the performance are very bad!

Cutscene: 28 - 29.2x FPS

In-game: 0.4 - 3.62 FPS


Emulator version:  RPCS3 v0.0.17-12637-cad96cef Alpha


Ryzen 5600X
Nvidia GTX 1660 Super
32 GB DDR4 @ 3600MHz
Windows 10 Pro


PPU Decoder: LLVM
SPU Decoder: ASMJIT (or LLVM)
Renderer: Vulkan (Open GL results in partially invisible menus and button prompts during quick time events)
Strict Rendering Mode = true (most in-game graphics are invisible without it)

Status: In-game. Prologue fully playable without issue. Game locks up shortly after the start of Episode 1 (see screenshot). Attempting to skip the cutscene results in the same error. Most of the time, I would receive this error while the game freezes and the music continues to play: 

E VM: Access violation writing location 0xffdead00 (unmapped memory) [type=u32]

Other times I'd receive this message when the game freezes and music stops:

F SIG: Thread terminated due to fatal error: Unknown/illegal channel in WRCH (ch=32 [ch32], value=0x30b)
(in file D:\a\1\s\rpcs3\Emu\Cell\SPUThread.cpp:4265[:22], in function set_ch_value)

Regardless which error occurs, it freezes in the exact same spot every time. Tried various combinations of settings and (different PPU and SPU decoders, Open GL, write color buffers, etc) and no dice. A shame since the game plays and performs great during the prologue battles and cutscenes. 

This game is so far playable for me on v0022-13648. It does exactly what @swagford1780 described, however this can be bypassed by either boosting PPU accuracy, or using PPU interpreter(much slower), as per here:

Namely I kept LLVM and enabled "accurate PPU saturation bit" and "PPU vector NaN fixup" in advanced->core, + "accurate PPU 128 reservations" to "always enabled" in debug tab.
EDIT: I also enabled "accu. cache line stores" in debug.

With these, I passed mentioned section and continued bit further, there were no problems and FPS was capped to 30 most of the time. I did not bother increasing SPU accuracy and neither accu. RSX reserv. was needed. Longer playtime is needed to confirm playable status but look fine to me so far.