RPCS3 Forums

Full Version: [BLUS30443] Demon's Souls vulkan crashes
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hi so the issue I'm having with RPCS3 is that whenever I try to play the game with vulkan it'll always end up crashing at the exact same point in the tutorial, if I try openGL it works fine but the framerate isn't that great (I imagine vulkan will be the same I just want to test mostly) but if I try to swap out to vulkan after finish the tutorial I'll wind up crashing as soon as I try to goto the boletarian palace (world 1) mid load. This is where I crash everytime during the tutorial https://i.imgur.com/3PQxVds.jpg

Specs; i5-6400, rx 480 4gb, 8gb ddr4 ram, windows 10, 64 bit.

Settings; https://i.imgur.com/SQnEPsI.png

RPCS3 version; currently v0.0.3-3-334327d alpha although I've tried multiple differen't versions some of which are shown working with vulkan on video.

Driver versions; AMD drivers version 17.8.2 (the latest), vulkan version 1.6.0 & vulkan api version 1.0.51.

Very sorry I tried adding an attachment of my log and it didn't popup, http://www.mediafire.com/file/rdcrz0c9wnc0pw2/RPCS3.rar this should work.
Still crashing on the latest version of everything, would be nice to have someone look at this and possibly help.
I have the same issue
Im having a similar issue. Though mine freezes and crashes usually just before the menu screen.
Try clicking "Disable Vertex Cache" in GPU configuration. That fixed it for me.