RPCS3 Forums

Full Version: Problems running own-dumped games
You're currently viewing a stripped down version of our content. View the full version with proper formatting.


Hello everyone

I'm new here but I tried to run my games many times on rpcs3... without success...Undecided

I own a PS3, a consequent library of (mainly japanese) games and a 'LG BD BH16NS40' drive on PC...
I tried to dump some of them using the method described in the quickstart guide but the resulting dumped disc always fail to load in rpcs3 with the error message:
E LDR: Invalid or unsupported file format: J:\Temp\PS3-discs\BLJM60215/PS3_GAME/USRDIR/EBOOT.BIN
(this is for my japanese version of Catherine)

In fact, I think I have the same decrypting problem as user Matstriker had on this thread: http://www.emunewz.net/forum/showthread....amp;page=6

I patch my .iso with .ird file in 'PS3 ISO Patcher'--> OK message
But when I use 'isoTools 1.34.9' to open/decrypt my patched .iso I always get the following message:
20:38: Using Default Keys
20:38: Using default public key
20:38: Drive E: is NOT a PS3 drive
20:38: Drive G: is NOT a PS3 drive
20:39: System.IO.FileLoadException: Invalid file type
   à IsoTools.Streams.IsoToolsStream..ctor(String path, Boolean calculateHash)
   à IsoTools.IsoCryptoClass.AnalyseISO(String fileName)
20:39: Failed, invalid ISO J:\Temp\PS3-discs\BLJM60215.ISO

I really don't understand why as I'm sure my .iso is correct (I use imgBurn to create it and I can access the disc's file structure without problem)...

If somebody got an idea to help me... thanks.