RPCS3 Forums

Full Version: PS3 Issues, Emulation Wins
You're currently viewing a stripped down version of our content. View the full version with proper formatting.


First off, I know this has nothing to do with rpcs3 other than I can't wait for the day that I can actually play my games on it instead of the junk hardware that Sony put together. So if this thread is not appropriate here, then please delete it. I am posting here because I've looked everywhere on the internet for people suffering the same issue with their PS3 but I can't find a single source with this issue.... And since you guys are working on a PS3 emulator, I'm assuming you have a better understanding of the system than most people out there.

First off my PS3 is an 80GB fat, and is the 3rd one I've owned. The other two are long gone, used for parts or got toasted in failed projects. Anyway this one works great, except it has a strange error where:
- blue light flashes
- disc pops out, kills the game I'm playing
- returns to XMB
- 3 beeps a few seconds later

Sometimes it goes nuts, and does 3 beeps over and over and over again. If I leave it in red light "standby" mode, sometimes it will turn itself on and do the process above. This makes me believe that its not overheating or the that the bluray is bad, because uh, its off. I pulled a bluray from an almost never used PS3 and tried two different drives. I tried multiple power supplies.

So am I SoL here? Maybe the motherboard is defective or the GPU and/or CPU is starting to separate from the board? I've tried refreshing the system and every other tactic that you can find online. Most searches for 3 beeps comes up with YLoD, but as far as I can tell this PS3 is okay so far and never had it.. yet.

The up side is sometimes it won't do it for hours and hours. I've been playing trails of cold steel, sometimes 5 hours at a time and it won't happen the entire session. Sometimes I won't see the issue for a week, others I can't even get past the intro without it happening 10 times.

Any insight into what this issue is and/or how I can fix it would be appreciated. And again, if this is not appropriate here then kindly remove this post since it's not really related to the emulator. With that said, I look forward to rpcs3 progress especially after dealing with this.
Very intermittent failures like that (when not overheating) usually indicate a power supply or motherboard issue. As you already tried a different power supply I would say BGA failure on the motherboard due to age and heat...


Thanks for the reply. That was my guess as well, it's such a shame these fat consoles had this design failure. I'm getting close to the end of Cold Steel but I still have the 2nd one to play, so here's hoping it holds out until after I finish that one. The current rate of puking the disc out seems to be only once every 2-4 hours, but oddly it doesn't do the triple beep every time now which is somewhat scary, although sometimes it still beeps like mad. It's strange because it almost feels like it was programmed to happen. As in, it goes from playing the game, to a "Please Wait" screen, then does all that junk I mentioned before.

I've done the heat gun trick in the past on my second PS3 but that only lasts so long. I eventually tried to delid it to replace the TIM and hoped it would stay cool enough that the solder wouldn't remelt, but unfortunately that didn't go so well and I ended up destroying it. I really regret selling the first one now... I might just grab a super slim eventually if this one craps out, but it's a shame that Sony put out junk and I might have to buy yet another PS3 just to play these games.
It's strange though. I've had three beeps happen when a game crashes for one reason or another (cfw modules). You wouldn't think say BGA failure would cause a soft crash like that. Maybe it's something stupid like a bad hard drive?

In any case, if you have lost all hope a first generation slim with cfw shouldn't cost more than $200/200€ (that's what I paid about a year ago) And they can run almost any PS2 games too via the emulator (if you care).


You know... I never would have considered the hard drive until you mentioned it because I was so fixated on the idea that the BGA solder was failing because it's such a common issue and does the same triple beep, plus it's what ended the life of my last PS3. The hard drive being bad never once crossed my mind which is almost shameful.

So I backed up all my saves, tore out the old drive, and plopped in a 60GB OCZ Agility SSD I happened to have laying around (leftover from when I upgraded my PC's SSD awhile back). Went through setting everything back up, installing the game, updating, blah blah.. and I'll be damned. I don't want to get ahead of myself, but I've had it running for almost 12 hours straight now with about 7 hours of game time and the issue hasn't happened once! It definitely, definitely would have happened by now, so this seems to have fixed the issue! You mentioning the HD saved me money and sanity, thanks dude!
Nice! Not too surprising though, that original drive might be almost 10 years old by now (check the label). I also remembered that I had a corrupted game once and that cause a lock up and three beeps shutdown. A bad drive could feed bad data or time out and have the same effective symptoms.

I run an old and busted 128 GB SSD in my PS3, and even if that SSD is garbage by modern computer standards it does wonders for the overall performance. It could be worth the upgrade, just get the cheapest oldest model you can find, it doesn't matter for this purpose.