RPCS3 Forums

Full Version: Issues compiling on Linux
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

thatguyehler

I've been trying to compile RPCS3 from git, to no avail. I'm on Linux, specifically Elementary OS. I've been trying various things for a few hours now, but I can't get past this error. Any suggestions?

Quote:[email protected]:~/rpcs3$ cd rpcs3 && cmake CMakeLists.txt && make && cd ../
-- cotire 1.7.3 loaded.
-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is GNU 4.8.4
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Initializing RPCS3_SRC_DIR=/home/justin/rpcs3/rpcs3
-- Found wxWidgets: TRUE
-- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8&quotWink
-- Found OpenGL: /usr/lib/x86_64-linux-gnu/libGL.so
-- Found OpenAL: /usr/lib/x86_64-linux-gnu/libopenal.so
-- dir='/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0'
-- dir='/usr/include/wx-3.0'
-- dir='/usr/lib/x86_64-linux-gnu/wx/include/gtk2-unicode-3.0'
-- dir='/usr/include/wx-3.0'
-- dir='/usr/include/AL'
-- dir='/usr/lib/llvm-3.6/include'
-- dir='/home/justin/rpcs3/rpcs3/../ffmpeg/linux/x86_64/include'
-- dir='/home/justin/rpcs3/rpcs3'
-- dir='/home/justin/rpcs3/rpcs3/Loader'
-- dir='/home/justin/rpcs3/rpcs3/Crypto'
-- dir='/home/justin/rpcs3/rpcs3/..'
-- dir='/home/justin/rpcs3/rpcs3/../asmjit/src/asmjit'
-- dir='/home/justin/rpcs3/rpcs3/../glm'
-- CXX target rpcs3 cotired excluding /home/justin/rpcs3/rpcs3/Emu/Cell/PPULLVMRecompiler.cpp.
-- Configuring done
-- Generating done
-- Build files have been written to: /home/justin/rpcs3/rpcs3
Scanning dependencies of target GitVersion
[ 0%] Generating something_that_never_exists
-- Found Git: /usr/bin/git (found version "1.9.1&quotWink
-- GIT_VERSION: 3864-68608ef
[ 0%] Built target GitVersion
[ 0%] Generating CXX prefix source cotire/rpcs3_CXX_prefix.cxx
[ 1%] Generating CXX prefix header cotire/rpcs3_CXX_prefix.hxx
[ 1%] Building CXX precompiled header cotire/rpcs3_CXX_prefix.hxx.gch
c++: error: unrecognized command line option ‘-std=c++14’
CMake Error at cmake_modules/cotire.cmake:1703 (message):
cotire: error 1 precompiling
/home/justin/rpcs3/rpcs3/cotire/rpcs3_CXX_prefix.hxx.
Call Stack (most recent call first):
cmake_modules/cotire.cmake:3233 (cotire_precompile_prefix_header)


make[2]: *** [cotire/rpcs3_CXX_prefix.hxx.gch] Error 1
make[1]: *** [CMakeFiles/rpcs3.dir/all] Error 2
make: *** [all] Error 2
[email protected]:~/rpcs3/rpcs3$

tambre

(11-22-2015, 03:48 AM)thatguyehler Wrote: [ -> ]I've been trying to compile RPCS3 from git, to no avail. I'm on Linux, specifically Elementary OS. I've been trying various things for a few hours now, but I can't get past this error. Any suggestions?

Could you try updating to a newer version of GCC? I'd suggest you to upgrade to GCC 4.9 or 5.0. As I'm afraid, that GCC 4.8.* might not have some features, that we use, anyway.

EDIT:
GCC 4.9 should be the minimum version, at which RPCS3 compiles. Definently upgrade your GCC.

thatguyehler

Thank you very much! I knew it had to be something silly like that, I just couldn't figure out what...
(11-22-2015, 03:49 PM)thatguyehler Wrote: [ -> ]Thank you very much! I knew it had to be something silly like that, I just couldn't figure out what...

Did you build it successfully on GCC 4.9? Did you have to change anything else? Just want to know the state of things.

thatguyehler

I built it successfully on GCC 5.2, which is the latest version. No trouble at all after upgrading.