RPCS3 Forums

Full Version: D3D12 backend, a couple of issues
You're currently viewing a stripped down version of our content. View the full version with proper formatting.


Hi, there is a couple of issues I have found lately, which doesnt happen with OpenGL backend.

An assertion failed window shows up when either Write Depth Buffer or Write Color Buffer are activated in Braid [NPUB30133] (also found in other games).

When Depth Buffer enabled:

[Image: eCJcVyx.png]

When Color Buffer enabled:

[Image: umy3eNI.png]

Another error occurs with Vertex Shader, which can not recognise the identifier "ivec4":

Quote:E {RSXThread} VS build failedBig Grin:\rpcs3\VertexProgram.hlsl(72,2-6): error X3000: unrecognized identifier 'ivec4'
D:\rpcs3\VertexProgram.hlsl(72,8-9): error X3000: unrecognized identifier 'a0'

E {RSXThread} LoadProgram failed.

This error shows up with Machinarium [NPEB00257] and Tank Battles Trial Version [NPEB00158].

As I said, It only happens with DirectX 12. I tested It with commit gc407c78, but with previous builds also happened. I tried various SPU and PPU configurations with no difference.

EDIT: I attach the Vertex Program and logs.


Does Braid require write color/depth buffer ? They can often be left unchecked in most app

The write depth buffer implementation was only tested against depth_read.elf sample. Write color buffer implementation is still not tested since I didn't find a sample/app/game that uses Cell to modify rtt before reusing them.

Anyway thanks for the report, will investigate.


As It is stated in this post, Braid needed color/depth buffer enabled with OpenGL in order to show textures (in a last year commit). At the moment, It doesn't show a single thing even with OpenGL, but the assert happens.


I fixed the crash with ivec4 in dx12 in Machinarium. However, the game only display a black screen...but GL also only show a black screen.


Ok, thanks for all your effort anyway. I'll check a couple of games that also showed this error when your commits get (or got (?), my english...) merged.